GuppY, le CMS de référence sans base de données

 
Recherche
 
Fermer

telecharger01.png

logo_nuxit_guppy.png
Vous êtes ici :   Accueil » Forum » Guppy 5 » Catastrophe après migration 5.0 -> 5.0.2.0.1
 
Prévisualiser...  Imprimer...  Imprimer la page...
Prévisualiser...  Imprimer...  Imprimer la section...
Forum - Guppy 5 - Catastrophe après migration 5.0 -> 5.0.2.0.1

Connectés :
 


le 13/11/2017 @ 21:17
par thierryARSAUT

thierryARSAUT

1 message

Utilisateur de Guppy depuis des années, je passe ce soir de la 5.0 de 2014 à la dernière 5.0.2.0.1 et là, catastrophe après migration 5.0 -> 5.02.01.

J'ai un message STOP ! Tentative d'intrusion détectée ! lorsque je vais à l'administration une fois les anciens fichiers écrasés en FTP par la dernière version.

Pire : si je vais au site http://www.basqueletters.com/Guitare/ ça me dit Insufficient version of PHP (5.2.17) : 5.4.0 or higher necessary

J'ai beau aller à Nuxit (mon hébergeur depuis des années, selon les conseils de Guppy), rien ne me dit comment passer à ce satané PHP 5.4.0, je n'ai que 5.3 disponible et je ne sais pas comment basculer le Nuxit dans le bon PHP. Y'a rein qui me dit si ça vient bien de ça où d'une autre chose dans le nouveau Guppy.

C'est bien la première fois que c'est la catastrophe, mais quelle catastrophe ! Mon site est KO après des années d'utilisation. Hier soir, mes potes s'en servaient encore pour charger des partitions de musique irlandaise, ce soir tout est foutu.

J'ai le moral dans les chaussettes.

Qu'est-ce que je dois faire ?


Rectifié par thierryARSAUT le 13/11/2017 @ 22:18
Poster une réponse Haut  

Réponse n° 1
--------
le 13/11/2017 @ 21:31
par thierryARSAUT

thierryARSAUT

2 messages

Bon, premier progrès, j'ai réussi à passer le PHP en 5.3.

Fallait juste cliquer sur un putain de tout petit bouton en forme de crayon pour éditer la config chez Nuxit.

ça va pas mieux, toujours les mêmes mauvais messages, STOP ! Tentative d'intrusion détectée ! et  Insufficient version of PHP (5.2.17) : 5.4.0 or higher necessary

mais au moins le moral se redresse, y'a eu comme un tout petit progrès en forme de ... putain de petit crayon !

Ce qui est bizarre, c'est que j'ai ajouté les lignes

AddHandler x-httpd-php5 .php AddType application/x-httpd-php5 .php

dans le .htaccess, retransferé lesdit fichier et j'ai quand même le pb PHP 5.4.0 or higher. Normal, Nuxit ne me proposait que le PHP 5.3 donc je reste marron...

Hallelujah ! Il fallait partir changer le mot de passe dans la section MySQL pour changer l'hébergement Nuxit en PHP 5.5. Allez comprendre la logique de ces jeunes informaticiens ! Bon, je passe une étape dans la vallée du désespoir et me voilà devant mon site http://www.basqueletters.com/Guitare/

Surprise ! Maintenant, je me croirais chez Guppy. Mon site a disparu ! Heureusement, je clique sur le bouton Admin en haut à droite et hop! Nouveau message désespérant :

STOP ! Tentative d'intrusion détectée ! Warning: Unknown: The session id is too long or contains illegal characters, valid characters are a-z, A-Z, 0-9 and '-,' in Unknown on line 0Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/web/basqueletters/session) in Unknown on line 0

Je suis encore désespéré, mais légèrement moins... Et je reste bloqué après une simple mise à jour Guppy. Pourtant j'en ai déjà fait une dizaine mais là, c'est la cata comme jamais.

Que faire ?

Je pense que j'ai fait une grosse eirennoc (verland poli), j'ai pris le pack 5.02.01 au lieu de prendre le patch cumulatif 5.02.01. Pas de panique, je re-écrase mes fichiers avec la sauvegarde que j'avais faite hier, en prévision...

On va bientôt voir si :

1 - je récupère bien mon site, car je crois bien avoir bouzillé mon .htaccess, j'avais pas mis l'option fichiers invisibles lors de la sauvegarde !

2 - si c'était bien l'histoire du patch cumulatif...

Quel suspense intenable.

Bon, ouf, j'ai déjà retrouvé mon site après restore de la sauvegarde.

Je tente la copie du patch cumulatif et là, c'est toujours le désespoir... J'obtiens le message :

Warning: substr() expects parameter 3 to be long, string given in /web/basqueletters/www/LLB/Guitare/admin/includes.inc on line 67 STOP ! Tentative d'intrusion détectée ! Warning: Unknown: The session id is too long or contains illegal characters, valid characters are a-z, A-Z, 0-9 and '-,' in Unknown on line 0 Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/web/basqueletters/session) in Unknown on line 0

à peu près clair comme de la pisse de rat.

Du coup, je restore à nouveau la sauvegarde, et j'attends que quelqu'un du forum de me donne une piste pour installer cette diable de mise à jour 5.02.01.

En attendant, je passe mon hébergement Nuxit en PHP 5.6, maintenant que je sais ce que signifie le putain de petit crayon à droite de mon nom de domaine chez Nuxit.

Donc je ne sais plus où j'en suis entre le patch cumulatif ou pas, je suis en

J'ai suivi la recommandation et ça a planté gravement, comme je l'avais jamais vu depuis ma première version de Guppy (je crois que ça s'appelait différemment au début).


Rectifié par thierryARSAUT le 13/11/2017 @ 23:45
Poster une réponse Haut  
Réponse n° 2
--------
le 14/11/2017 @ 03:35
par JeandePeyrat

JeandePeyrat

Administrateur
2854 messages

Bonjour,

Inutile de traiter tout et tout le monde de péripatéticienne cry

Pour ce qui est de l'aide NUXIT c'est ICI

Sinon pour patcher et  non migrer en version 5.02.01 il faut utiliser le patch cumulatif 5.02.01 et bien suivre les consignes affichées en rouge au moment de télécharger.

Ensuite il y a le Centre d'aide GuppY pour avoir toutes les consignes complémentaires et en dernier ressort ce forum

Cordialement,

Jean

Poster une réponse Haut  
Réponse n° 3
--------
le 14/11/2017 @ 18:54
par thierryARSAUT

thierryARSAUT

3 messages

Merci JeanDePeyrat,

Merci pour le lien de l'aide Nuxit d'abord, qui ne saute plus franchement aux yeux sur la nouvelle interface de chez Nuxit. Il faut cliquer sur Support, puis encore chercher le pavé Besoin d'aide ?, puis cliquer encore sur Accéder au centre d'assistance. Un simple "Aide" aurait suffit et économisé le jeu de piste. ça fait depuis mon passage de la 4.6 à la 5.0.10 que je ne touche plus à mon site Guppy autrement que pour le remplir et depuis cette époque, c'est franchement devenu compliqué à loisir, faut aimer faire des clics pour faire des clics, tout ce que j'exècre. Bon, là encore passons, le fouilli PHP c'est du côté de chez Nuxit. Je pense que c'est réglé de ce côté-là.

Mais alors pourquoi l'aide de Guppy recommande de regarder sa version et que cette version recommande de passer le Pack complet (preuve ci-dessous) au lieu du Patch cumulatif ? on s'y perd. La logique y devient floue.

Version de GuppY

Après avoir suivi la recommandation ci-dessus et catastrophé la mise à jour, je suis revenu sur ma sauvegarde et j'ai aussi fait le coup du patch cumulatif.

Pour un résultat aussi mauvais. A 55 ans, je sais lire et comprendre mais il faut bien avouer qu'une interminable page où on mélange allègrement le rouge, le gras, le souligné, les allusions à la version 5.01.02 puis à la 5.00.07 (aucun ordre logique), puis re à la 5.00.11 puis retour à la 5.01.02 puis à la 5.01.03 puis à la 5.01.04 et enfin à la 5.02.01, ben à la fin on est paumé et on fait "au feeling, comme la précédente fois".

Merci encore d'essayer de me sauver la situation, mais ce que vous suggérez, je crois que je l'ai déjà fait.

Voilà ce que j'ai fait et refait :

- sauvegardé mon site en FTP,

- copié en FTP tous les fichiers du patch cumulatif par-dessus ceux de mon site,

- exécuté http://votre_site/maj_index_arom.php

- essayé d'aller en Admin pour revalider toutes les pages de config

- ça s'est mis à générer des messages d'erreurs comme les boulets à Gravelotte.

J'utilise Guppy depuis la version 2 (peut-être même un peu avant) mais là, c'est bien la première fois qu'une màj se passe mal comme ça.

Je me dis que j'ai dû perdre la main quelque part où alors passer à côté d'une ligne écrite en noir, mais vachement importante, et que je n'ai pas vue au milieu de tout ce rouge...

Encore merci pour les rappels, mais là, je ne sais plus quoi faire.


Rectifié par thierryARSAUT le 14/11/2017 @ 18:56
Poster une réponse Haut  
Réponse n° 4
--------
le 14/11/2017 @ 20:54
par thierryARSAUT

thierryARSAUT

4 messages

à JeanDePeyrat,

y'a un net progrès, mais ça coince quand même.

J'ai lu pleins d'autres trucs, notamment l'aide sur la fonction Installer.

J'ai donc installé le patch cumulatif (incroyablement simple, la procédure semble fonctionner) et ça a l'air de marcher sauf que j'ai eu le message suivant :

Warning: substr() expects parameter 3 to be long, string given in /web/basqueletters/www/LLB/Guitare/inc/includes.inc on line 109

mais après revalidation des pages de config, tout semble remarcher.

Seul problème, j'ai perdu le focus central de mes articles et quand un utilisateur se connecte, ça perd le login.

Bref, la màj se passe toujours mal.

Bon sang que c'est devenu compliqué pour faire marcher un truc qui marchait impeccablement en 2014.

Poster une réponse Haut  
Réponse n° 5
--------
le 14/11/2017 @ 21:27
par thierryARSAUT

thierryARSAUT

5 messages

à JeanDePeyrat,

y'a un nouveau progrès, mais ça coince toujours.

Après avoir réglé le thème sur skn5_guppy2015, j'ai récupéré un look qui ressemble à ce que j'avais avant. Au passage, adieu ma skin précédente, surtout le fond en gris dégradé qui était si beau.

Encore deux problèmes qui subsistent :

  1. j'ai le bouton Admin qui traîne en haut à droite et je ne me souviens plus comment l'enlever, mais je pense que je vais y arriver,
  2. quand je me connecte avec un user, le système affiche Bienvenue puis quitte la connection et reviens à l'accueil, impossible de se connecter et voir les articles ! Site toujours HS mais ça se rapproche.

Comment faire pour faire marcher le système d'identification ?

Poster une réponse Haut  
Réponse n° 6
--------
le 14/11/2017 @ 22:32
par thierryARSAUT

thierryARSAUT

6 messages

Rien à faire, impossible de faire fonctionner le système de connections.

Je restore les sauvegardes pour la 5ième fois...

Cette 5.02.01, côté install c'est le ponpon, du jamais vu.

Je ne suis pas le seul à avoir ce genre de pbs mais étant dessus depuis les débuts d'Aldweb, je dois faire maintenant partie des vétérans utilisateurs de Guppy et là, je dois avouer que je patine sur-place.

Poster une réponse Haut  
Réponse n° 7
--------
le 14/11/2017 @ 23:24
par thierryARSAUT

thierryARSAUT

7 messages

Bon maintenant, après restoration de la sauvegarde, j'ai le message

Mot de passe : ERREUR !

et je n'arrive plus à entrer en administration de mon site !

ça fait 4 fois que je restore et ça déconne toujours.

c'est de pire en pire, j'ai perdu le moral tout ça parce que j'ai voulu faire la màj.

Mon site est perdu, foutu, même si je restore les sauvegardes pour la 7ième fois, je ne suis plus admin !

Poster une réponse Haut  
actif sujet actif   clos sujet clos   Important! Important!   Nouveau Nouveau message
Rectifier Rectifier message   Clôturer Clôturer sujet   Remonter Remonter  
Catégories de discussion  Forum  



Vous êtes ici :   Accueil » Forum » Guppy 5 » Catastrophe après migration 5.0 -> 5.0.2.0.1
 
Préférences

Se reconnecter :
Votre nom (ou pseudo) :
Votre mot de passe
pT93
Recopier le code :


  13261527 visiteurs
  34 visiteurs en ligne

Connectés :
membresPapinou (GT)
Newsletter
Pour avoir des nouvelles de ce site, inscrivez-vous à notre Newsletter.
pT93
Recopier le code :
Site enregistré à la CNIL sous l'agrément 1040387.
Vous disposez d'un droit d'accès, de modification, de rectification
et de suppression des données selon la loi Informatique et Liberté (article 34) du 6 janvier 1978.

FreeGuppY.org est hébergé sur un serveur dédié Nuxit


 


Nuxit Partenaire de GuppY
 

    gy_twitter02.png