En poursuivant votre navigation sur ce site, vous acceptez l'utilisation de cookies pour vous proposer des contenus et services adaptés. Mentions légales.
 

GuppY, le CMS de référence sans base de données

telecharger01.png

Vous êtes ici :   Accueil » Forum » Guppy 5 » MAJ Guppy
 
Prévisualiser...  Imprimer...  Imprimer la page...
Prévisualiser...  Imprimer...  Imprimer la section...

Attention : GuppY 5.02.09, mise à jour des zips

Sortie de GuppY 5.02.09 :

Les zips du pack, du patch cumulatif et du patch non-cumulatif sont mis à jour au 07.06.2019 à 18h30 avec la correction du fil d' ariane pour les articles, la correction de l'affichage des archives des nouvelles, la correction du lien du logo dans le mail pour l'inscription des membres.

Si vous avez patché votre site avant le 07.06.2019 à 18h30, vous devez télécharger le patch non-cumulatif à nouveau et le réinstaller avec la fonction Installer.

Désolé, toutes nos excuses pour ce contretemps, tous nos remerciements pour les signalements.

Le patch CKEditor v4121 pour GuppY 502xx (06.07.2019) est en téléchargement dans la rubrique Télécharger puis GuppY 5. Merci à Saxbar pour cette mise à jour.

Mise à jour des listes de blocage des spams (08.07.2019) pour Apache 2.3 et pour Apache 2.4 en téléchargement dans la rubrique Télécharger puis GuppY 5.

Forum - Guppy 5 - MAJ Guppy


Connectés : ( personne )
Snif !!!
 

actif  Sujet n° 130502

le 07/06/2019 @ 11:04
par ericbreizh

Anonyme

visiteur

Bonjour,

Je reprends les sujets d'un collegue et je dois mettre a jour le guppy qu'il avait mis en place.

le guppy est en version v5.00.11

j'ai lu cette page : https://www.freeguppy.org/fgy5dn.php?lng=fr&tconfig=0#z2

Je suis obligé de faire toutes les actions indiqués ?

je ne comprends pas bien, c'est difficile a comprendre cette page smile

si quelqu'un peut me dire comment mettre a jour avec la dernière version ?

Merci

Poster une réponse Haut  

Réponse n° 1
--------
le 07/06/2019 @ 11:19
par Saxbar

Saxbar

Développeur
15 messages

Bonjour,

Le CMS GuppY est en évolution permanente. Il est donc conseillé, voire nécessaire, de mettre à jour au fur et à mesure en tenant des impératifs de chacune des mises à jour.

Donc oui, pour mettre à jour ton GuppY il faut télécharger le patch cumulatif 5.02.09 sur cette page https://www.freeguppy.org/fgy5dn.php?lng=fr&pg=274237&tconfig=0#z2 et bien suivre les consignes.

La principale difficulté sera le paramétrage de la skin avec Config look, étape indispensable.

Une autre difficulté sera l'accès à l'admin qui est modifié pour mesure de sécurité.

Le guide pour toutes ces opérations se trouve sur le site GHC https://ghc.freeguppy.org/index.php?lng=fr.

En cas de problème nous pourrons t'aider ici.

Bon courage.

Cordialement, Saxbar.

Site web Saxbar
Poster une réponse Haut  
Réponse n° 2
--------
le 07/06/2019 @ 11:35
par ericbreizh

Anonyme

visiteur

Pour l'instant en tout cas, j'ai un autre souci :

Je n'ai plus l'accès à l'interface admin "error 500". Il y a quelque jour avait été configuré les vhost dans apache et ce matin j'ai fait les MAJ sur le serveur Ubuntu.

Je ne sais pas lequel des 2 manipulations a casser l'accès à l'admin.

dans les logs apache, j'ai des warning et une seule fatal error :

[Fri Jun 07 11:30:59.593194 2019] [php7:error] [pid 3859] [client 10.10.10.9:56818] PHP Fatal error:  require_once(): Failed opening required '/var/www/html/procedures/inc/mobile_detect.php' (include_path='.:/usr/share/php') in /var/www/html/procedures/inc/hpage.inc on line 40, referer: http://procedures.toto.lan/

L'accès au site fonctionne, juste l'accès admin qui déconne

 

Poster une réponse Haut  
Réponse n° 3
--------
le 07/06/2019 @ 12:08
par ericbreizh

Anonyme

visiteur

La version de php :

PHP 7.2.19-0ubuntu0.18.04.1 (cli) (built: Jun  4 2019 14:48:12) ( NTS )  

Poster une réponse Haut  
Réponse n° 4
--------
le 07/06/2019 @ 12:22
par ericbreizh

Anonyme

visiteur

autres logs suite a la commande : /usr/bin/php7.2 /var/www/html/procedures/index.php

PHP Fatal error:  Uncaught Error: Call to undefined function import() in /var/www/html/procedures/inc/includes.inc:64 Stack trace: #0 /var/www/html/procedures/index.php(19): include() #1 {main}   thrown in /var/www/html/procedures/inc/includes.inc on line 64

Poster une réponse Haut  
Réponse n° 5
--------
le 07/06/2019 @ 14:25
par ericbreizh

Anonyme

visiteur

Warning: include_once(): Failed opening '/var/www/html/procedures/inc/constantes.php' for inclusion (include_path='.:/usr/share/php') in /var/www/html/procedures/inc/functions.php on line 40 Warning: Use of undefined constant CONFIG - assumed 'CONFIG' (this will throw an Error in a future version of PHP) in /var/www/html/procedures/inc/includes.inc on line 38 Warning: include(CONFIG): failed to open stream: No such file or directory in /var/www/html/procedures/inc/includes.inc on line 38 Warning: include(): Failed opening 'CONFIG' for inclusion (include_path='.:/usr/share/php') in /var/www/html/procedures/inc/includes.inc on line 38 Warning: Use of undefined constant USER_COOKIE - assumed 'USER_COOKIE' (this will throw an Error in a future version of PHP) in /var/www/html/procedures/inc/includes.inc on line 89 Warning: Use of undefined constant USER_COOKIE - assumed 'USER_COOKIE' (this will throw an Error in a future version of PHP) in /var/www/html/procedures/inc/includes.inc on line 164 Warning: Use of undefined constant INCEXT - assumed 'INCEXT' (this will throw an Error in a future version of PHP) in /var/www/html/procedures/inc/includes.inc on line 172 Warning: Use of undefined constant INCEXT - assumed 'INCEXT' (this will throw an Error in a future version of PHP) in /var/www/html/procedures/inc/includes.inc on line 175 Warning: include(../skins/no_skin/skinINCEXT): failed to open stream: No such file or directory in /var/www/html/procedures/inc/includes.inc on line 175 Warning: include(): Failed opening '../skins/no_skin/skinINCEXT' for inclusion (include_path='.:/usr/share/php') in /var/www/html/procedures/inc/includes.inc on line 175 Warning: Use of undefined constant INCEXT - assumed 'INCEXT' (this will throw an Error in a future version of PHP) in /var/www/html/procedures/inc/includes.inc on line 177 Warning: Use of undefined constant INCEXT - assumed 'INCEXT' (this will throw an Error in a future version of PHP) in /var/www/html/procedures/inc/includes.inc on line 180 Warning: include(../skins/no_skin/confskinINCEXT): failed to open stream: No such file or directory in /var/www/html/procedures/inc/includes.inc on line 180 Warning: include(): Failed opening '../skins/no_skin/confskinINCEXT' for inclusion (include_path='.:/usr/share/php') in /var/www/html/procedures/inc/includes.inc on line 180 Warning: Use of undefined constant INCREP - assumed 'INCREP' (this will throw an Error in a future version of PHP) in /var/www/html/procedures/inc/includes.inc on line 184 Warning: Use of undefined constant INCEXT - assumed 'INCEXT' (this will throw an Error in a future version of PHP) in /var/www/html/procedures/inc/includes.inc on line 184 Warning: include(../INCREPlang/-webINCEXT): failed to open stream: No such file or directory in /var/www/html/procedures/inc/includes.inc on line 184 Warning: include(): Failed opening '../INCREPlang/-webINCEXT' for inclusion (include_path='.:/usr/share/php') in /var/www/html/procedures/inc/includes.inc on line 184 Warning: Use of undefined constant INCREP - assumed 'INCREP' (this will throw an Error in a future version of PHP) in /var/www/html/procedures/inc/includes.inc on line 185 Warning: Use of undefined constant INCEXT - assumed 'INCEXT' (this will throw an Error in a future version of PHP) in /var/www/html/procedures/inc/includes.inc on line 185 Warning: include(../INCREPlang/-helpINCEXT): failed to open stream: No such file or directory in /var/www/html/procedures/inc/includes.inc on line 185 Warning: include(): Failed opening '../INCREPlang/-helpINCEXT' for inclusion (include_path='.:/usr/share/php') in /var/www/html/procedures/inc/includes.inc on line 185 Warning: Use of undefined constant INCREP - assumed 'INCREP' (this will throw an Error in a future version of PHP) in /var/www/html/procedures/inc/includes.inc on line 186 Warning: Use of undefined constant INCEXT - assumed 'INCEXT' (this will throw an Error in a future version of PHP) in /var/www/html/procedures/inc/includes.inc on line 186 Warning: include(../INCREPlang/-adminINCEXT): failed to open stream: No such file or directory in /var/www/html/procedures/inc/includes.inc on line 186 Warning: include(): Failed opening '../INCREPlang/-adminINCEXT' for inclusion (include_path='.:/usr/share/php') in /var/www/html/procedures/inc/includes.inc on line 186 Warning: Use of undefined constant INCREP - assumed 'INCREP' (this will throw an Error in a future version of PHP) in /var/www/html/procedures/inc/includes.inc on line 206 Warning: Use of undefined constant INCREP - assumed 'INCREP' (this will throw an Error in a future version of PHP) in /var/www/html/procedures/inc/includes.inc on line 207 Warning: Use of undefined constant INCREP - assumed 'INCREP' (this will throw an Error in a future version of PHP) in /var/www/html/procedures/inc/includes.inc on line 210 Warning: include(../INCREPlog.inc): failed to open stream: No such file or directory in /var/www/html/procedures/inc/includes.inc on line 210 Warning: include(): Failed opening '../INCREPlog.inc' for inclusion (include_path='.:/usr/share/php') in /var/www/html/procedures/inc/includes.inc on line 210 Warning: Use of undefined constant DBLOGDATE - assumed 'DBLOGDATE' (this will throw an Error in a future version of PHP) in /var/www/html/procedures/inc/log_stats.inc on line 23 Warning: Use of undefined constant DBLOGDATE - assumed 'DBLOGDATE' (this will throw an Error in a future version of PHP) in /var/www/html/procedures/inc/log_stats.inc on line 24 Warning: Use of undefined constant DATAREP - assumed 'DATAREP' (this will throw an Error in a future version of PHP) in /var/www/html/procedures/inc/security.inc on line 18 Warning: file_put_contents(../DATAREPsecurity/ban_cfg.ini): failed to open stream: No such file or directory in /var/www/html/procedures/inc/security.inc on line 59 Warning: Use of undefined constant ADM5_COOKIE - assumed 'ADM5_COOKIE' (this will throw an Error in a future version of PHP) in /var/www/html/procedures/admin/admin.php on line 36 Warning: Cannot modify header information - headers already sent by (output started at /var/www/html/procedures/inc/includes.inc:185) in /var/www/html/procedures/admin/admin.php on line 36 Warning: Use of undefined constant MEMBERSCOL - assumed 'MEMBERSCOL' (this will throw an Error in a future version of PHP) in /var/www/html/procedures/inc/func_groupscol.php on line 68 Warning: Use of undefined constant REDACREP - assumed 'REDACREP' (this will throw an Error in a future version of PHP) in /var/www/html/procedures/admin/admin.php on line 94 Warning: Use of undefined constant INCEXT - assumed 'INCEXT' (this will throw an Error in a future version of PHP) in /var/www/html/procedures/admin/admin.php on line 94 Warning: Use of undefined constant ADM_COOKIE - assumed 'ADM_COOKIE' (this will throw an Error in a future version of PHP) in /var/www/html/procedures/admin/admin.php on line 116 Warning: Use of undefined constant ADM_COOKIE - assumed 'ADM_COOKIE' (this will throw an Error in a future version of PHP) in /var/www/html/procedures/admin/admin.php on line 213 Fatal error: require_once(): Failed opening required '/var/www/html/procedures/inc/mobile_detect.php' (include_path='.:/usr/share/php') in /var/www/html/procedures/inc/hpage.inc on line 40  

Poster une réponse Haut  
Réponse n° 6
--------
le 07/06/2019 @ 14:28
par Papinou

Papinou

Administrateur
547 messages

Bonjour,

Je ne sais pas si c'est la raison mais j'ai lu sur ce site qu'il y avait des problèmes avec PHP 7.2.19.

Je suis passé en local avec Wamp en 7.3.6, tout fonctionne.

Je vais tester avec 7.2.19 et je reviens te dire.

Cordialement, Papinou

Poster une réponse Haut  
Réponse n° 7
--------
le 07/06/2019 @ 14:47
par Papinou

Papinou

Administrateur
548 messages

Bonjour,

Vu tous les warnings et tous les affichages sur la page d'accueil en 7.2.19, tu devrais essayer une autre version de PHP, la 7.2.18 fonctionnait, les 7.3.x fonctionnent.

Impossible de me connecter en admin, j'ai dû forcer le passage.

Je suis revenu en 7.3.6 et tout fonctionne à nouveau.

Cordialement, Papinou

Poster une réponse Haut  
actif sujet actif   clos sujet clos   Important! Important!   Nouveau Nouveau message
Rectifier Rectifier message   Clôturer Clôturer sujet   Remonter Remonter  
Catégories de discussion  Forum  



Vous êtes ici :   Accueil » Forum » Guppy 5 » MAJ Guppy
 
Prévisualiser...  Imprimer...  Imprimer la page...
Prévisualiser...  Imprimer...  Imprimer la section...

Préférences


Se reconnecter :
Votre nom (ou pseudo) :
Votre mot de passe
<O>


  14098449 visiteurs
  12 visiteurs en ligne

Connectés :
( personne )
Snif !!!

Newsletter

Pour avoir des nouvelles de ce site, inscrivez-vous à notre Newsletter.

Avant de soumettre ce formulaire, veuillez lire et accepter les Mentions légales.

J'accepte :
Recopier le code :
Site enregistré à la CNIL sous l'agrément 1040387.
Vous disposez d'un droit d'accès, de modification, de rectification
et de suppression des données selon la loi Informatique et Liberté (article 34) du 6 janvier 1978.

 
FreeGuppY.org est hébergé sur un serveur dédié o2switch
gy_twitter02.png