En poursuivant votre navigation sur ce site, vous acceptez l'utilisation de cookies pour vous proposer des contenus et services adaptés. Mentions légales.
 
 
 

GuppY, le CMS de référence sans base de données

 

telecharger.png

 
Vous êtes ici :   Accueil » Forum » Guppy 5 » Warning : Erreur fatale
 
 
 
    Imprimer la page...
    Imprimer la section...

Attention : GuppY 5.03.02

Sortie de GuppY 5.03.02 :
 

Les zips du pack, du patch cumulatif et du patch non-cumulatif sont en téléchargement le 10.03.2020 à 17h00.
 

Pour les plugins et pour les skins, merci de poster sur le site de leur auteur.
 

Le patch CKEditor v4121 pour GuppY 502xx (06.07.2019) est en téléchargement dans la rubrique Télécharger puis GuppY 5. Merci à Saxbar pour cette mise à jour.

Mise à jour des listes de blocage des spams (24.09.2019) pour Apache 2.3 et pour Apache 2.4 en téléchargement dans la rubrique Télécharger puis GuppY 5

Forum - Guppy 5 - Warning : Erreur fatale


Connectés :
 

clos par Schmol44 le 05/01/2020 @ 11:18  Sujet n° 130706

le 18/12/2019 @ 22:38
par Schmol44

Schmol44

762 messages

Bonjour à tous et merci de toutes ces évolutions.

Ces derniers temps, je n'ai pas eu beaucoup de temps pour mon site.

Je viens de faire une sauvegarde et comme d'habitude, je viens de la patcher de la V5.02.09 à la V5.03.00 en local et j'ai le Warning suivant :

Fatal error: Cannot redeclare htable() (previously declared in C:EasyPHP-Devserver-16.1eds-wwwGuppy_V50300-18122019skinsskn5_HC_2015skin.inc:34) in C:EasyPHP-Devserver-16.1eds-wwwGuppy_V50300-18122019incfuncskin.inc on line 24

D'avance merci pour la réponse, à cette question (pas urgent, mon site en ligne fonctionne)

Amicalement, Schmol44

Site web Schmol44
sujet clos Haut  

Réponse n° 1
--------
le 18/12/2019 @ 23:09
par Papinou

Papinou

Administrateur
805 messages

Bonsoir Henri,

Tu n'as pas dû suivre nos conseils pour patcher en utilisant la fonction Installer.

Donc le fichier skin.inc n'est pas mis à jour.

Tu télécharges le pack GuppY 5.03.00 et tu prends le fichier skin.inc d'une des skins du pack.

Cordialement, Papinou

Site web Papinou
clos par Schmol44 le 05/01/2020 @ 11:18 Haut  
Réponse n° 2
--------
le 19/12/2019 @ 09:28
par Schmol44

Schmol44

763 messages

Bonsoir Yves,

Tu sais bien que ça n'est pas dans mes habitudes de ne pas suivre vos conseils.

Effectivement, je pensais que cette procédure n'était pas applicable en local, il y a un moment que je n'avais pas mis à jour en local.

Honte à moi.

Rassures toi, en ligne j'utilise bien cette fonction.

J'ai bien vu qu'il s'agissait de la skin, mais je ne voyais pas le remède.

Une fois de plus, merci pour tes précieux conseils.

Bonne journée.

Je viens de faire la modif, ayant eu une déformation importante de la page d'accueil, j'ai refait complètement une mise à jour avec la fonction "installer" et ça n'est pas mieux, j'obtiens 2 warnings :

Warning: Invalid argument supplied for foreach() in C:EasyPHP-Devserver-16.1eds-wwwGuppy_V50300-18122019inchpage.inc on line 527 Warning: Invalid argument supplied for foreach() in C:EasyPHP-Devserver-16.1eds-wwwGuppy_V50300-18122019inchpage.inc on line 538
et une déformation de la page d'accueil.
Merci pour la suite à donner. cry

Amicalement, Schmol44


Rectifié par Schmol44 le 19/12/2019 @ 10:00
Site web Schmol44
clos par Schmol44 le 05/01/2020 @ 11:18 Haut  
Réponse n° 3
--------
le 19/12/2019 @ 21:43
par Papinou

Papinou

Administrateur
809 messages

Bonsoir Henri,

Tu revalides les pages de config boîtes principale, secondaire, WEB, MOBILE ensuite Accueil/blog

Puis Ctrl+F5 pour afficher la page sans passer par le cache.

Cordialement, Papinou

Site web Papinou
clos par Schmol44 le 05/01/2020 @ 11:18 Haut  
Réponse n° 4
--------
le 20/12/2019 @ 23:24
par Schmol44

Schmol44

764 messages

Bonsoir Papinou,

Désolé, j'ai eu quelques urgences à régler, me revoici, me revoila.

J'ai pas mal galéré avec "EasyPhp" car je n'arrivais pas à avoir 2 installations similaires (Sauvegarde de mon site actuel) sous 2 noms différents bien entendu, car je voulais avoir une sauvegarde en 5.02.09 et la nouvelle en 5.03.00.

La seconde n'affichait que des Warnings. Le problème est réglé, mais dans aucune des 2 je ne peux plus me connecter en "admin". La connexion s'effectue, admin apparait et disparait. (ça me rappelle une certaine version)

Même chose sur une V5.02.08, installée là depuis longtemps et qui fonctionnait parfaitement..

Bref, j'ai réinstallé Wamp, avec également 2 sauvegardes sous les 2 noms différents.

Mais là, je rencontre 2 difficultés avant même de patcher la mise à jour.

J'ai un Warning sur les 2 installations qui sont des copies conforme de ma sauvegarde, ce qui prouve également que le pb rencontré plus haut ne vient pas de cette sauvegarde.

Warning: A non-numeric value encountered in C:wampwwwV50209-19122019incfunctions.php on line 1986

C:wampwwwV50209-19122019incbpage.inc' )

D'avance merci

Amicalement, Schmol44


Rectifié par Schmol44 le 20/12/2019 @ 23:26
Rectifié par Schmol44 le 21/12/2019 @ 09:03
Site web Schmol44
clos par Schmol44 le 05/01/2020 @ 11:18 Haut  
Réponse n° 5
--------
le 21/12/2019 @ 10:58
par Schmol44

Schmol44

765 messages

Bonjour à tous,

J'ai un peu avancé : (toujours en V5.02.09 pour migrer localement en V5.03.00)

EasyPhp, j'ai changé de version et je suis passé en DevServer 17 avec Apache en 2.4.25 au lieu de 2.4.18.

Je me suis retrouvé avec le même Warning qu'avec Wamp. (Voir ci-dessus)

En fait j'étais en php 7.13.86, je l'ai ramené en php 7.1.13, c'était la même chose, finalement je l'ai mis en php 5.6.

Maintenant, je me connecte en admin, mais ne peux plus me déconnecter.

Je suis passé à Wamp, lui le Php était en 7.3.12, je l'ai passé en 7.1.35, toujours le warning, je l'ai donc mis en 5.6.4.

Plus de Warning et lui je me connecte et me déconnecte d'admin sans problème. Reste à essayer la migration.

Bonne journée à tous.

Amicalement, Schmol44

Site web Schmol44
clos par Schmol44 le 05/01/2020 @ 11:18 Haut  
Réponse n° 6
--------
le 21/12/2019 @ 13:49
par Papinou

Papinou

Administrateur
813 messages

Bonjour,

Je ne reproduis pas avec Wamp et GuppY 5.02.09 avec PHP 7.3.12.

Avec Wamp + PHP 7.4.0 et GuppY 5.03.00, je n'ai pas de warning.

Il faut dire que notre ami Saxbar a fait le nécessaire pour adapter GuppY 5.03.00 pour le PHP 7.4.0

Cordialement, Papinou

Site web Papinou
clos par Schmol44 le 05/01/2020 @ 11:18 Haut  
Réponse n° 7
--------
le 21/12/2019 @ 15:05
par Schmol44

Schmol44

766 messages

Bonjour Yves,

Bizarre, vous avez dit Bizarre, j'ai pourtant fait plusieurs essais.

Et pour mon histoire de non déconnexion en admin sous "devserv", tu as une idée ?

En attendant, je vais tenter une mise à jour avec Wamp puisque ça fonctionne.

Par contre, quelque chose m'a étonné dans la 1ère migration que j'avais faite, il y a maintenant dans la config des boites, 5 colonnes au lieu de trois, comment remettre chaque boite à sa place ?

Amicalement, Schmol44


Rectifié par Schmol44 le 21/12/2019 @ 15:06
Site web Schmol44
clos par Schmol44 le 05/01/2020 @ 11:18 Haut  
actif sujet actif   clos sujet clos   Important! Important!   Nouveau Nouveau message
Rectifier Rectifier message   Clôturer Clôturer sujet   Remonter Remonter  
Catégories de discussion  Forum