En poursuivant votre navigation sur ce site, vous acceptez l'utilisation de cookies pour vous proposer des contenus et services adaptés. Mentions légales.
 
 
 

GuppY, le CMS de référence sans base de données

 

telecharger.png

 
Vous êtes ici :   Accueil » Forum » Guppy 5 » Warning : Erreur fatale
 
 
 
    Imprimer la page...
    Imprimer la section...

Attention : GuppY 5.03.02

Sortie de GuppY 5.03.02 :
 

Les zips du pack, du patch cumulatif et du patch non-cumulatif sont en téléchargement le 10.03.2020 à 17h00.
 

Pour les plugins et pour les skins, merci de poster sur le site de leur auteur.
 

Le patch CKEditor v4121 pour GuppY 502xx (06.07.2019) est en téléchargement dans la rubrique Télécharger puis GuppY 5. Merci à Saxbar pour cette mise à jour.

Mise à jour des listes de blocage des spams (24.09.2019) pour Apache 2.3 et pour Apache 2.4 en téléchargement dans la rubrique Télécharger puis GuppY 5

Forum - Guppy 5 - Warning : Erreur fatale


clos par Schmol44 le 05/01/2020 @ 11:18  Sujet n° 130706

le 18/12/2019 @ 22:38
par Schmol44

Schmol44

762 messages

Bonjour à tous et merci de toutes ces évolutions.

Ces derniers temps, je n'ai pas eu beaucoup de temps pour mon site.

Je viens de faire une sauvegarde et comme d'habitude, je viens de la patcher de la V5.02.09 à la V5.03.00 en local et j'ai le Warning suivant :

Fatal error: Cannot redeclare htable() (previously declared in C:EasyPHP-Devserver-16.1eds-wwwGuppy_V50300-18122019skinsskn5_HC_2015skin.inc:34) in C:EasyPHP-Devserver-16.1eds-wwwGuppy_V50300-18122019incfuncskin.inc on line 24

D'avance merci pour la réponse, à cette question (pas urgent, mon site en ligne fonctionne)

Amicalement, Schmol44

Site web Schmol44
sujet clos Haut  
Réponse n° 1
--------
le 18/12/2019 @ 23:09
par Papinou

Papinou

Administrateur
805 messages

Bonsoir Henri,

Tu n'as pas dû suivre nos conseils pour patcher en utilisant la fonction Installer.

Donc le fichier skin.inc n'est pas mis à jour.

Tu télécharges le pack GuppY 5.03.00 et tu prends le fichier skin.inc d'une des skins du pack.

Cordialement, Papinou

Site web Papinou
clos par Schmol44 le 05/01/2020 @ 11:18 Haut  
Réponse n° 2
--------
le 19/12/2019 @ 09:28
par Schmol44

Schmol44

763 messages

Bonsoir Yves,

Tu sais bien que ça n'est pas dans mes habitudes de ne pas suivre vos conseils.

Effectivement, je pensais que cette procédure n'était pas applicable en local, il y a un moment que je n'avais pas mis à jour en local.

Honte à moi.

Rassures toi, en ligne j'utilise bien cette fonction.

J'ai bien vu qu'il s'agissait de la skin, mais je ne voyais pas le remède.

Une fois de plus, merci pour tes précieux conseils.

Bonne journée.

Je viens de faire la modif, ayant eu une déformation importante de la page d'accueil, j'ai refait complètement une mise à jour avec la fonction "installer" et ça n'est pas mieux, j'obtiens 2 warnings :

Warning: Invalid argument supplied for foreach() in C:EasyPHP-Devserver-16.1eds-wwwGuppy_V50300-18122019inchpage.inc on line 527 Warning: Invalid argument supplied for foreach() in C:EasyPHP-Devserver-16.1eds-wwwGuppy_V50300-18122019inchpage.inc on line 538
et une déformation de la page d'accueil.
Merci pour la suite à donner. cry

Amicalement, Schmol44


Rectifié par Schmol44 le 19/12/2019 @ 10:00
Site web Schmol44
clos par Schmol44 le 05/01/2020 @ 11:18 Haut  
Réponse n° 3
--------
le 19/12/2019 @ 21:43
par Papinou

Papinou

Administrateur
809 messages

Bonsoir Henri,

Tu revalides les pages de config boîtes principale, secondaire, WEB, MOBILE ensuite Accueil/blog

Puis Ctrl+F5 pour afficher la page sans passer par le cache.

Cordialement, Papinou

Site web Papinou
clos par Schmol44 le 05/01/2020 @ 11:18 Haut  
Réponse n° 4
--------
le 20/12/2019 @ 23:24
par Schmol44

Schmol44

764 messages

Bonsoir Papinou,

Désolé, j'ai eu quelques urgences à régler, me revoici, me revoila.

J'ai pas mal galéré avec "EasyPhp" car je n'arrivais pas à avoir 2 installations similaires (Sauvegarde de mon site actuel) sous 2 noms différents bien entendu, car je voulais avoir une sauvegarde en 5.02.09 et la nouvelle en 5.03.00.

La seconde n'affichait que des Warnings. Le problème est réglé, mais dans aucune des 2 je ne peux plus me connecter en "admin". La connexion s'effectue, admin apparait et disparait. (ça me rappelle une certaine version)

Même chose sur une V5.02.08, installée là depuis longtemps et qui fonctionnait parfaitement..

Bref, j'ai réinstallé Wamp, avec également 2 sauvegardes sous les 2 noms différents.

Mais là, je rencontre 2 difficultés avant même de patcher la mise à jour.

J'ai un Warning sur les 2 installations qui sont des copies conforme de ma sauvegarde, ce qui prouve également que le pb rencontré plus haut ne vient pas de cette sauvegarde.

Warning: A non-numeric value encountered in C:wampwwwV50209-19122019incfunctions.php on line 1986

C:wampwwwV50209-19122019incbpage.inc' )

D'avance merci

Amicalement, Schmol44


Rectifié par Schmol44 le 20/12/2019 @ 23:26
Rectifié par Schmol44 le 21/12/2019 @ 09:03
Site web Schmol44
clos par Schmol44 le 05/01/2020 @ 11:18 Haut  
Réponse n° 5
--------
le 21/12/2019 @ 10:58
par Schmol44

Schmol44

765 messages

Bonjour à tous,

J'ai un peu avancé : (toujours en V5.02.09 pour migrer localement en V5.03.00)

EasyPhp, j'ai changé de version et je suis passé en DevServer 17 avec Apache en 2.4.25 au lieu de 2.4.18.

Je me suis retrouvé avec le même Warning qu'avec Wamp. (Voir ci-dessus)

En fait j'étais en php 7.13.86, je l'ai ramené en php 7.1.13, c'était la même chose, finalement je l'ai mis en php 5.6.

Maintenant, je me connecte en admin, mais ne peux plus me déconnecter.

Je suis passé à Wamp, lui le Php était en 7.3.12, je l'ai passé en 7.1.35, toujours le warning, je l'ai donc mis en 5.6.4.

Plus de Warning et lui je me connecte et me déconnecte d'admin sans problème. Reste à essayer la migration.

Bonne journée à tous.

Amicalement, Schmol44

Site web Schmol44
clos par Schmol44 le 05/01/2020 @ 11:18 Haut  
Réponse n° 6
--------
le 21/12/2019 @ 13:49
par Papinou

Papinou

Administrateur
813 messages

Bonjour,

Je ne reproduis pas avec Wamp et GuppY 5.02.09 avec PHP 7.3.12.

Avec Wamp + PHP 7.4.0 et GuppY 5.03.00, je n'ai pas de warning.

Il faut dire que notre ami Saxbar a fait le nécessaire pour adapter GuppY 5.03.00 pour le PHP 7.4.0

Cordialement, Papinou

Site web Papinou
clos par Schmol44 le 05/01/2020 @ 11:18 Haut  
Réponse n° 7
--------
le 21/12/2019 @ 15:05
par Schmol44

Schmol44

766 messages

Bonjour Yves,

Bizarre, vous avez dit Bizarre, j'ai pourtant fait plusieurs essais.

Et pour mon histoire de non déconnexion en admin sous "devserv", tu as une idée ?

En attendant, je vais tenter une mise à jour avec Wamp puisque ça fonctionne.

Par contre, quelque chose m'a étonné dans la 1ère migration que j'avais faite, il y a maintenant dans la config des boites, 5 colonnes au lieu de trois, comment remettre chaque boite à sa place ?

Amicalement, Schmol44


Rectifié par Schmol44 le 21/12/2019 @ 15:06
Site web Schmol44
clos par Schmol44 le 05/01/2020 @ 11:18 Haut  
Réponse n° 8
--------
le 21/12/2019 @ 15:18
par Saxbar

Saxbar

Développeur
75 messages

Bonjour Henri,

Oui, dorénavant pour top et bottom il y a 5 emplacements.

L'ordre qui existait en 5.02.09 peut être conservé en 5.03.00, les emplacements vides ont une longueur nulle donc pas de soucis de décalages.

Il y a longtemps que j'ai abandonné EasyPhp au profit de Wampserver plus pratique, et surtout totalement gratuit.

Cordialement, Saxbar.

Site web Saxbar
clos par Schmol44 le 05/01/2020 @ 11:18 Haut  
Réponse n° 9
--------
le 21/12/2019 @ 21:06
par Schmol44

Schmol44

767 messages

Bonjour Lud,

Merci pour ton intervention,

Par précaution, j'utilise les 2 depuis un bon moment et c'est vrai que j'aimais bien "EasyPhp".Mais comme je suis têtu, j'ai voulu aller jusqu'au bout et en fait je l'avais installé dans "Program File".

Je l'ai réinstallé à la racine de C: et ma version 5.02.09 fonctionne maintenant en admin et je peux me déconnecter. C'est déjà ça.

Mais le site met un temps fou à se connecter et à me donner la main.

Je vais donc faire la migration sous "Wamp" et je te remercie pour l'information sur "Top et Bottom", ça m'avait intrigué, mais depuis, j'ai passé pas mal de temps à la réinstallation de mes 2 supports.

Je vais me lancer.

Quand je vois toutes les modifications sur cette nouvelle version, je dis "chapeau" à la Team et à toi en tant que développeur.

Quel boulot ça doit représenter. Bravo à vous tous.

Perso, je ne sais pas programmer et je le regrette mais je suis passionné par le dépannage des PC et en ce moment je ne m'ennuie pas avec la fin de l'assistance de "Windows 7" et l'évolution vers "Windows 10".

La passion de l'informatique est un "bouffe temps", mais quel plaisir quand ça fonctionne.

Je pensais que cette mise à jour était de la rigolade et je me suis rendu compte qu'il fallait que je révise mes connaissances et que je l'attaque avec sérieux.

Un grand merci à vous tous pour ce superbe logiciel qui a évolué de façon magistrale.

Il y a quelques années, je donnais des cours d'informatique et de construction de sites, bénévolement dans une Association de quartier et j'avais coutume de dire que "Guppy", c'était facile, ç'était comme un jeu de "Légo" pour les enfants.

Cela a bien changé. cool

Amicalement, Schmol44

Site web Schmol44
clos par Schmol44 le 05/01/2020 @ 11:18 Haut  
Réponse n° 10
--------
le 24/12/2019 @ 08:12
par Schmol44

Schmol44

768 messages

Bonjour à tous,

Juste pour information.

Décidément, je ne croyais pas si bien dire, mon passe temps préféré a pris le dessus.

Attention à l'usage des touches "Ctrl + F5", bien utiles pourtant pour rafraichir une page sans cache.

Perso, j'en ai fait l'usage et malheureusement, j'ai fait une mauvaise manip involontairement.

j'ai appuyer sur la touche "Ctrl" avec mon index gauche et sur la touche "F5" avec  mon index droit, du moins, c'est ce que je croyais, en fait mon index gauche a appuyer sur 2 touches à la fois, "Ctrl" + FN", ces 2 touches étant voisines et l'autre sur "F5".

3 Touches, il n'a pas aimé, résultat, j'ai planté mon PC, immédiatement, je l'ai redémarré, impossible.

En mode sans échecs, j'ai tenté toutes les réparations possibles, rien à faire.

Décidément cette nouvelle mise à jour m'a crée de sacrés problèmes, j'espère en voir le bout.

Ne faites pas comme moi,

"JOYEUX NOËL A TOUS"

Amicalement, Schmol44


Rectifié par Schmol44 le 24/12/2019 @ 08:15
Site web Schmol44
clos par Schmol44 le 05/01/2020 @ 11:18 Haut  
Réponse n° 11
--------
le 04/01/2020 @ 21:08
par Schmol44

Schmol44

769 messages

Bonsoir à tous et Bonne Année 2020

Pour faire suite au plantage de mon PC décrit ci-dessus, il est enfin opérationnel,

"Windows 10" ayant refusé toute réparation automatique, j'ai du créer une clé USB pour réinstaller "Windows 10" et tout le contenu.

Après avoir réinstaller "Filezilla", "WampServer64" et "NotePad + +" pour pouvoir mettre à jour mon site, je suis de nouveau prêt à faire cette modification.

Au départ, Php en V7.3.12, j'obtiens le même Warning qu'avant,

En Php V7.0.33, plus de Warning, mais toutes les boites du sites sont ouvertes et je ne peux même pas les fermer.

En Php V5.6.40, même chose.

Une petite aide pour démarrer l'opération, me serait fort utile.

D'avance Merci

Amicalement, Schmol44


Rectifié par Schmol44 le 04/01/2020 @ 21:09
Site web Schmol44
clos par Schmol44 le 05/01/2020 @ 11:18 Haut  
actif sujet actif   clos sujet clos   Important! Important!   Nouveau Nouveau message
Rectifier Rectifier message   Clôturer Clôturer sujet   Remonter Remonter