GuppY, le CMS de référence sans base de données

 
Recherche
 
Fermer

telecharger01.png

logo_nuxit_guppy.png
Vous êtes ici :  Accueil
 
Prévisualiser...  Imprimer...  Imprimer la page...
Toujours plus avec GuppY 5.02.01  !!!
 
poisson.png

Pour parler de vous

fanfare.png

Pour partager votre passion

ecole.png

Pour partager vos recherches

guppy.png

Concentrez-vous sur le contenu, GuppY s'occupe de (presque) tout le reste !

frame.png

  • Vous voulez construire un site pour présenter vos passions, documenter un logiciel que vous utilisez, partager vos photos, parler de vous ou communiquer avec autrui ?

     
  • Vous avez envie d'un site complet, interactif, avec un livre d'or, un blog,  un forum,des nouvelles, un annuaire, une FAQ, une galerie... et la possibilité de l'afficher sur tous les supports?

     
  • Vous n'avez malheureusement aucune connaissance en HTML, PHP, mySQL ?
     
  • Pour un site responsive sur tous les appareils, simplement avec la configuration mobile,

    c'est GuppY 5  qu'il vous faut pour votre site !!!

Après GuppY 5.01, " responsive design", "mobile-friendly", une nouvelle évolution : GuppY 5.02.01 !
 

Le changement le plus important est la gestion des cookies pour des raisons de compatibilité avec les pare-feux applicatifs proposés sur certains hébergements mutualisés.
Il ne subsiste que deux cookies, celui du membre connecté et éventuellement celui du captcha image. Vous pourrez apercevoir deux autres cookies, GuppYSite et GuppYAdmin qui sont eux des cookies de session, donc générés par le PHP.
 

Trois évolutions visibles parmi les évolutions et nouveautés :
- le remplacement de PGEditor par une version de CKEditor sécurisée,
- l'ajout d'un effet parallaxe sur les trois zones principales et sa gestion dans Config look.
- le blocage au scroll du menu ou d'un menu déroulant horizontal en haut de page.
 

La procédure recommandée pour l'installation du patch non cumulatif GuppY 5.02.00 :
- pré-requis: PHP 5.4 minimum, l'utilisation de PHP 5.6 ou de PHP 7.1 est possible sans aucun problème
- télécharger et installer le patch avec la fonction Installer en admin, fermer et relancer votre navigateur, les anciens cookies doivent être éliminés
- se reconnecter comme membre de votre site et vous rendre en admin et  valider les pages de configs habituelles.
 

Tous nos remerciements :
- à tous les participants à cette évolution de GuppY 5.02.00, à tous nos testeurs,
- à tous les utilisateurs de GuppY pour leur soutien, leur fidélité,

Pour les remerciements et autres commentaires sympathiques, pensez au Livre d'Or de freeGuppY ... Merci !!!
 

La GuppY Team

Forum en direct

Tout re-marche en version 5.02.01. Sauf que... j'y reviens après, en fin de post. Pour l'instant, voilà la solution appliquée. Contexte : Firefox Quantum 57 64 bits, la précision semble importante car la gestion des cookies et du cache a un effet connu sur la résolution des problèmes d'accès en Admin Windows 8.1 passage de Guppy 5.00.10 à 5.02.01 Voici la démarche suivie : restoration FTP par le service de mon hébergeur (Nuxit) de tout le dossier de mon site Guppy je suis revenu alors en 5.00.10 perte de l'accès Admin avec message Mot de passe : ERREUR ! Dans l'ordre : suppression des cookies Firefox par le menu Option>Vie privée et sécurité>supprimer des cookies spécifiques. de Firefox. suppression de tout les identifiants mémorisés par firefox par le menu Option>Formulaires et mots de passe>identifiants mémorisés. de Firefox. Attention, j'ai fait apparaître les mots de passe et je les ai écrits exactement identiques sur un bout de papier, pour ne pas les oublier. suppression du cache mémoire de firefox par Option>Contenu web en cache>Vider maintenant. dans Firefox. restoration FTP du seul fichier du site dans le dossier //MonSiteGuppy/Admin/mdp.php. Connection au mode admin de mon site directement par http//www.MonSiteGuppy.com/admin/admin.php. ça marche ! je suis dedans ! validation sans tarder de toutes les options du menu Configurations de l'administration validation immédiatement après de la liste des membres par Administration Générale>Liste des membres. Le fil d'Ariane de Guppy (en haut) indique Accueil » Admin > Gestion des membres , ce n'est pas très cohérent mais l'idée est la même. déconnexion du mode Admin Reconnexion avec un user lambda : tout remarche ! Reconnexion en mode Admin : tout remarche ! A ce stade, je suis revenu en 5.00.10, je vais vite mettre la skin de base en no_skin, afin de préparer la mise à jour en 5.02.01, c'est important, déconnexion du mode Admin Reconnexion avec un user lambda : tout remarche. Voilà comment j'ai pu tout récupérer de mon site en version 5.00.10. La doc Guppy précise que le patch cumulatif est à appliquer dans mon cas : "Deux cas se présentent à vous, soit votre GuppY est dans la version précédente (par exemple 5.00.11 pour passer en 5.01.00), soit il est dans une version plus ancienne (5.00.xx avec x compris entre 00 et 10 inclus). Dans le premier cas, vous utiliserez le patch non cumulatif 5.01.00 qui permet de passer de la version 5.00.11 à la version 5.01.00 . Dans le second cas, vous utiliserez le patch cumulatif 5.01.00, qui contient tous les correctifs de la version 5.0.1 jusqu'à la version 5.01.00 . Il permet de passer de n'importe quelle version 5.00.xx à la dernière version." Initialement, j'avais déjà appliqué le patch cumulatif 5.02.01 via le mode Admin de Guppy par Administration Générale>Installer. Mais ce coup-ci, j'ai pris la précaution de mettre la skin de base sur no_skin AVANT de lancer la mise à jour. Je précise que j'ai bien lu tout ce qui se présentait sous mes yeux et que j'ai fini par lire ceci avant de lancer la mise à jour : "Ce patch cumulatif comporte toutes les corrections de   GuppY depuis  la version 5.0.0   ATTENTION ! Ce patch ne concerne que les versions de GuppY à partir de la version 5.0.0.Si vous avez une version de GuppY inférieure à 5.02.00-1, c'est ce patch cumulatif que vous devez télécharger pour passer en 5.02.01" Avec ma 5.00.10, je suis bien dans ce cas donc, je refais l'install du patch cumulatif 5.02.01 via le mode Admin de Guppy par Administration Générale>Installer. Le fil d'Ariane de Guppy (en haut) indique Accueil » Admin > Installer , ce n'est pas cohérent mais l'idée est quasi la même, je comprends bien ce que je fais. Plus tard, je ferais un post complet sur la cohérence de l'interface Admin et ses conséquences sur les WebMaistres qui exploitent Guppy moins fréquemment que d'autres systèmes logiciels. Pour l'instant, je pense avoir trouvé la bonne démarche et je lance la màj en ayant fait, auparavant, plusieurs contrôles d'intégrité. Tout s'annonce bien. Je charge le fichier gy_upg_50201.zip et je clique sur le bouton Installer ce fichier ZiP. A ce stade, je revalide les pages configs et liste des membres mais le message Mot de passe : ERREUR ! reviens lorsque je me reconnecte en Admin; J'ai la parade : j'exécute la routine des points 4 à 7 ci-dessus et je retrouve mes accès Admin et Users sur la version 5.02.01, mais avec la no_skin en décor. Normal me direz-vous, je l'avais positionnée avant de lancer la màj... Logiquement, si je récupère ma skin 5.00.10 précédente et que je la converti en ModeLook, ça devrait bien se passer. Je verrais ça plus tard. Pour l'instant, j'ai plusieurs "rechutes" de blocages de mot de passe Admin, avec quelques pertes de fonctions Admin encore inexpliquées, selon les users connectés, mais j'applique la parade des points 4 à 7 et je retombe toujours sur mes pattes. Vous l'avez compris, il semble que la gestion des cookies de Firefox Quantum 57, combinée à sa gestion de cache ait des influences non négligeables sur la robustesse d'utilisation de Guppy en mode Admin. Rectifié par thierryARSAUT le 18/11/2017 @ 14:51 ...
18/11/2017 @ 14:40
(par thierryARSAUT)
La dernière nouvelle
Sortie de GuppY 5.02.01 - Mise à jour de sécurité - par Guppy_Team le 30/08/2017 @ 14:25

logo.png
GuppY : Pack GuppY 5.02.01, patchs cumulatif et non-cumulatif - Mise à jour de sécurité.

 

Ce pack est la 99ème version de GuppY
 

Nous vous proposons le patch 5.02.01 avec des ajouts, des améliorations, des corrections et la correction d'une faille critique.
Merci à jchouix pour la découverte et le signalement de cette faille.


Attention, toutes les versions de GuppY sont concernées, sans exception, par cette faille critique.
Vous devez installer IMPERATIVEMENT et IMMEDIATEMENT ce patch 5.02.01 pour la sécurité de votre site.

 

Pré-requis : PHP 5.4 minimum

- choix des skins CKEditor public
- paramétrage des couleurs et taille des caractères de CKEditor public
- correction de la fonction getNewUpdateDoc()
- ajout de l'autorisation des réactions par article
- correction du contrôle de mot de passe admin
- indépendance de la partie admin
- rationalisation des fichiers de langue
- correction de l'inclusion de la classe phpmailer
- mise à jour de PhpMailer en version 5.2.23
- mise à jour de Mobile_detect en version 2.8.25
- contrôle de l'activation du formulaire Contact
- correction de l'activation du blocage d'une ligne TOP
- amélioration du contrôle de validité des courriels (merci jchouix)
- amélioration du filtrage de CKEditor public
- amélioration du paramétrage des cookies
- correction du lien archives des nouvelles (merci Laroche)
- ajout du choix des formats de date pour les deux langues
- ajout d'une règle css individuelle à chaque jour du calendrier
- correction de l'enregistrement des plugins
- ajout d'une fonction d'initialisation des galeries photos
- correction de la comparaison de version pour la mise à jour
- amélioration de Config look
- modification des droits d'accès à l'admin
- correction d'une faille critique
 

ATTENTION :

Deux patchs sont nécessaires pour rester dans la limite des 2Mo imposés par certains hébergeurs :

En premier avec la fonction Installer, vous mettez à jour CKEditor avec le patch-CKEditor-v472, disponible dans la rubrique Télécharger puis GuppY.

Pour passer de la version 5.02.00-1 à la version 5.02.01, c'est le patch gy-non-cumulative-50201 que vous devez utiliser, en suivant cette procédure :
    • télécharger le patch et installer en admin avec la fonction Installer de GuppY,
    • valider les pages de configuration habituelles

Après l'installation vous devez aller en admin/config look et procéder dans cet ordre :

    1. compléter la configuration des champs nouveaux dans Config look,
    2. enregistrer la config pour enregistrer vos modifications,
    3. cliquer sur "Générer Style" pour mettre à jour votre skin compatible Config look,  ensuite plusieurs rafraîchissements de l'affichage d'une page peuvent être nécessaires pour avoir un affichage correct.

Comme pour tous les patchs, il est conseillé de revalider toutes les pages de config en admin.


 

Modifications des archives :

Si vous avez téléchargé le pack complet GuppY 5.02.01, le patch cumulatif et le patch non-cumulatif avant le 30 Août 2017 à 14h00, vous devez télécharger à nouveau les zips.
Nous avons apporté des modifications à plusieurs fichiers de la version 5.02.01.

Dans tous les cas, vous devez installer le patch non-cumulatif gy-non-cumulative-50201 du 30.08.2017 pour mettre à jour vers la dernière version.

Merci pour vos signalements, merci pour votre compréhension.
 

 
Merci à Saxbar et à tous les participants à ce patch.
La GuppY Team


 


Le dernier billet

Notre partenaire Nuxit propose gratuitement un firewall (WAF) pour les hébergements standard ( Pack Mutu Perso, Pack Mutu Pro, Pack Mutu Illmité ) et les hébergements Performance ( Pack Mutu Performance 1, Pack Mutu Performance 2, Pack Mutu Performance 3, Pack Mutu Performance 4 ).

Si vous avez un hébergement antérieur à ces offres, vous devez upgrader pour pouvoir activer le firewall, c’est aussi le cas pour le certificat SSL pour l’accès à votre site de façon sécurisée en HTTPS.


L’activation est simple :

Vous vous connectez à la console manager Nuxit de votre espace en ligne,
Un clic sur la rubrique « Hébergement », puis un autre sur « Sous-Domaines ».

Dans la page affichée, vous allez à la rubrique : Liste des sous-domaines / Hôtes Virtuels.

Vous cliquez sur l’icône en forme de crayon devant le nom de votre domaine ou sous-domaine et la page d’édition du sous-domaine s’affiche :

firewall_nuxit.jpg

Comme vous pouvez le voir sur la copie d’écran, vous cochez « Firewall », vous sélectionnez « Activé », puis en bas du cadre d’édition vous cliquez sur « Modifier ».

Après quelques minutes, le firewall sera actif pour ce sous-domaine.

Le firewall (WAF) est une protection mod_security que vous pouvez activer pour chaque domaine et chaque sous-domaine.

C’est un firewall applicatif intégrant le jeu de règles OWASP visant à protéger votre site des attaques applicatives connues, notamment à l’encontre des sites utilisant un CMS comme GuppY.

Tous nos remerciements à l’équipe Nuxit pour leur disponibilité, pour leur aide et pour la prise en compte de nos demandes pour permettre l’activation du firewall avec GuppY 5.02

Nous recommandons l’activation du firewall, l’activation du certificat SSL pour la sécurité de vos sites.

Les attaques récentes montrent que sur les questions de sécurité, il faut être très vigilant même si cela engendre quelques désagréments.


La GuppY Team

Publié le 21/05/2017 @ 15:37 
Vous êtes ici :  Accueil
 
Préférences

Se reconnecter :
Votre nom (ou pseudo) :
Votre mot de passe
6dbc
Recopier le code :


  13261520 visiteurs
  28 visiteurs en ligne

Connectés :
membresPapinou (GT)
Newsletter
Pour avoir des nouvelles de ce site, inscrivez-vous à notre Newsletter.
6dbc
Recopier le code :
Site enregistré à la CNIL sous l'agrément 1040387.
Vous disposez d'un droit d'accès, de modification, de rectification
et de suppression des données selon la loi Informatique et Liberté (article 34) du 6 janvier 1978.

FreeGuppY.org est hébergé sur un serveur dédié Nuxit


 


Nuxit Partenaire de GuppY
 

    gy_twitter02.png