GuppY, le CMS de référence sans base de données

 
Recherche
 
Fermer

telecharger01.png

logo_nuxit_guppy.png
Vous êtes ici :   Accueil » Historique des versions
 
Prévisualiser...  Imprimer...  Imprimer la page...
Prévisualiser...  Imprimer...  Imprimer la section...
Le CMS GuppY
Derniers billets
Calendrier
rss Cet article est disponible en format standard RSS pour publication sur votre site web :
https://www.freeguppy.org/data/fr-articles.xml

GuppY : Pack GuppY 5.01.02, patchs cumulatif et non-cumulatif - 02 décembre 2015gylogo.png

 
Ce pack est la 92ème version de GuppY
 

Nous vous proposons le patch 5.01.02 avec des ajouts, des améliorations, des corrections:

- correction du nom du tableau date dans le calendrier du blog  by Saxbar
- mise à jour de CKEditor en version 4.5.4  by Saxbar
- mise à jour de la librairie jQuery en version 1.11.3  by Saxbar
- correction de la génération du style jqstyle.css  by Saxbar
- ajout de la numérotation des zones de saisie des fichiers de style (merci Rey)
- correction du traitement des dates du calendrier du blog (merci Papinou)
- correction du fil d'Ariane du module maintenance en admin  by Saxbar
- correction des constantes dans le module maintenance  by Saxbar
- correction dans l'entête du forum du lien pour la recherche en url-rw  by Saxbar
- correction du traitement des documents RSS  by Saxbar
- création de menus classiques basés sur des menus déroulants  by Saxbar
- création de menus déroulants basés sur des menus classiques  by Saxbar
- création de menus déroulants verticaux pour mobile  by Saxbar
- affichage WEB des tablettes avec largeur écran >= 1024  by Saxbar
- ajout du paramètre "Cacher la date de parution" des nouveautés du site  by Saxbar
- correction d'une adresse en url-rewriting  by Saxbar
- correction de la liste des catégories pour la création de galeries photos  by Saxbar
- amélioration du tableau des boîtes disponibles  by Saxbar
- ajout de propriétés texte pour le style des catégories des annuaires  by Saxbar
- ajout du contrôle d'accès des diaporamas de la boîte  by Saxbar
- gestion en zone membres avec les groupes privés  by Saxbar
- ajout de phpmailer dans contact.php  by Saxbar
- boîtes dynamiques dans les entêtes et bas de page  by Saxbar
- ajout d'un traitement personnalisé des erreurs 404  by Saxbar
- choix des pages secondaires pour l'affichage des menus icônes  by Saxbar
- choix des pages secondaires pour l'exécution des services  by Saxbar
- ajout d'une feuille de style pour chaque page secondaire  by Saxbar
- ajout des marges, de l'opacité, des Zones Centrales dans Config look  by Saxbar
- police de symboles "fontello" étendue  by Saxbar
- intégration du slider jquery "camera" (merci Jean-Denis)
- choix de la position des zones Contact par courrier et téléphone (merci Jean-Denis)

Pour passer de la version 5.01.01 à la version 5.01.02, c'est ce patch gy-non-cumulative-50102 que vous devez utiliser, et installer avec la fonction Installer de GuppY 5. Revalider les pages de config en admin, sans oublier Config sections.
 

Merci à tous les participants à ce patch.

La GuppY Team
 

GuppY : Pack GuppY 5.01.01, patchs cumulatif et non-cumulatif

Mise à jour de sécurité - 02 septembre 2015gylogo.png

 
Ce patch est la 91ème version de GuppY


Nous vous proposons le patch 5.01.01 avec des améliorations concernant la correction du traitement des erreurs. Merci à dipisoft pour son signalement.

Attention, toutes les versions de GuppY sont concernées, sans exception.
Vous devez installer IMPERATIVEMENT et IMMEDIATEMENT ce patch 5.01.01 pour la sécurité de votre site.

Ces ajouts, améliorations, corrections sont aussi dans ce patch:

- ajout de la sélection du mois et de l'année dans le calendrier du blog par Saxbar
- ajout de la sélection du délai d'expiration de la connexion par Saxbar
- ajout du chargement en admin du dossier admin/incadmin par Saxbar
- ajout du chargement de styleplus.css dans le popup de téléchargement par Saxbar
- possibilité de cacher un document dans l'une des deux langues en préfixant le titre par § par Saxbar
- ajout d'un drapeau d'activation du sondage par Saxbar
- ajout de la gestion des ancres nommées dans les barres de navigation par Saxbar
- activation/désactivation des sondages par Saxbar
- ajout des commentaires blog et des réactions articles dans les nouveautés du site par Saxbar
- ajout des paramètres nouveautés du site pour les mobiles par Saxbar
- ajout de la création d'option de menu pour les photoramas par Saxbar
- correction du test de validité dans postguest.php par Saxbar
- amélioration de la protection des répertoires par Saxbar (merci Papinou)
- correction de l'initialisation du tableau des destinataires par Saxbar (merci Laroche)
- correction du style d'un élément de tableau dans les réactions articles par Saxbar (merci Jean-Denis)
- correction de la fermeture des groupes des articles des menus par Saxbar (merci Jean-Denis)
- paramètre pour l'inversion de la colonne des boîtes du blog par Saxbar
- amélioré de l'archivage du forum par Saxbar
- correction de l'accès aux archives du forum par Saxbar (merci fpierric)
- correction de l'affichage du tableau des couleurs par Saxbar
 

Pour passer de la version 5.01.00 à la version 5.01.01, c'est ce patch gy-non-cumulative-50101 que vous devez utiliser.
 

Merci à tous les participants à ce patch.

La GuppY Team


 

gylogo.png GuppY : Pack GuppY 5.01.00, patchs cumulatif et non-cumulatif - 12 juin 2015
 

Ce pack est la 90ème version de GuppY.
 

Nous avons le plaisir de vous proposer le pack GuppY 5.01.00, « responsive design », « mobile-friendly », une nouvelle évolution !!!

Beaucoup de changements par rapport à la 5.00.11, même s'ils ne voient pas trop au premier abord pour les visiteurs.
La structure a été entièrement revue et modifiée pour être "responsive design" et répondre aux critères "mobile-friendly" de Google.

Nous avons retenu la solution d'un seul site responsive avec une configuration web pour les PC et une configuration mobile pour les autres appareils, GuppY détectant l'user-agent de l'appareil pour afficher la version correspondante.

Les modifications et corrections :
- création d'une structure double web et mobile par Saxbar et Papinou
- correction de l'affichage de la date de modification des articles par Saxbar
- remplacement des messages de sécurité par Saxbar (merci Ludo)
- ajout du paramètre hébergement derrière un proxy par Saxbar (merci jcp)
- mise à jour automatique de l'adresse du site par Saxbar
- ajout du paramètre de désactivation de l'impression des résultats de recherche par Saxbar
- correction du retour automatique à la ligne dans CKEditor par Saxbar
- boîte citations autorisée dans l'édito par Saxbar
- correction de la duplication des événements de l'agenda par Saxbar (merci Fred68)
- amélioration du tri des événements de l'agenda dans les nouveautés par Saxbar
- ajout de paramètres pour cacher les membres connectés et enregistrés par Saxbar
- amélioration de Config look par Saxbar
- amélioration de l'enregistrement dans la base pour les hébergements avec cache par Saxbar
- correction de règles de ré-écriture d'adresses par Saxbar
- correction des accès rapides d'admin par Saxbar
- correction de l'envoi de la supervision de suppression des préférences par Saxbar
- ajout d'un onglet de gestion des fontes additionnelles dans Config style par Saxbar
- déplacement du bouton "Créer la lettre avec les nouveauts du site" par Saxbar
- ajout du plugin "gestion de code" dans CKEditor par Saxbar
- suppression des icônes de validation W3C
 

Pour passer de la version 5.00.11 à la version 5.01.00, c'est le patch gy-non-cumulative-50100 que vous devez utiliser.
 

RAPPEL :

- Installer ce patch avec la fonction Installer de GuppY 5 est un plus indéniable, votre renommage anti-spam des fichiers sensibles est conservé, pour vos skins : la no_skin et votre skin d'origine sont mises à jour et fonctionnelles pour GuppY5.01,

Pour les autres skins de votre site, vous devez sélectionner les skins une par une en skin d'origine et exécuter le fichier maj_configmob.php en l'ajoutant à l'url de votre site : http://www.monsite.net/maj_configmob.php  pour chaque skin, puis rafraîchir la page pour avoir l'affichage correct.

- Si la fonction Installer n'est pas opérationnelle, vous devez remettre le nom d'origine à vos fichiers sensibles en Config services/Contributions visiteurs & anti-spam puis enregistrer,

 Envoyer le contenu du patch par FTP et remettre le même nom de renommage,

 Enfin pour les skins, vous devez sélectionner les skins une par une en skin d'origine et exécuter le fichier maj_configmob.php en l'ajoutant à l'url de votre site : http://www.monsite.net/maj_configmob.php  pour chaque skin, puis rafraîchir la page pour avoir l'affichage correct.

 

Merci à tous les participants à ce patch.

La GuppY Team
 

gylogo.png GuppY : Pack GuppY 5.00.11, patchs cumunlatif et non-cumulatif - 02 mars 2015

 

Ce patch est la 89ème version de GuppY.

 

Nous vous proposons le pack GuppY 5.00.11, avec les améliorations et corrections suivantes :

- amélioration de la fonction displayQuickConfig() par Saxbar
- uniformisation de la saisie du pseudo par Saxbar
- correction du lien article lors de la recherche par Saxbar (merci jerlal)
- amélioration de la gestion des collaborateurs par Saxbar
- correction des droits rédacteur niveau 1 par Saxbar
- correction du tri sur la date des événements de l'agenda par Saxbar
- amélioration de la duplication des événements de l'agenda par Saxbar
- correction du statut des nouveaux membres par Saxbar
- refonte du module Config look par Saxbar et Papinou
- correction de la suppression des membres par Saxbar
- correction de la liste des destinataires de la lettre d'information par Saxbar
- suppression de la sauvegarde entière du site par Saxbar
- ajout du dossier skins/ dans la liste des dossiers autorisés dans la gestion de fichiers par Saxbar
- amélioration de l'affichage du copyright par Saxbar
- correction du traitement des options de menu dans la boîte nouveautés du site par Saxbar
- amélioration du traitement de styleplus.css par Saxbar
- mise à jour de la librairie lightbox par Saxbar
- ajout d'une ancre nommée en bas de page par Saxbar
- ajout de la saisie du tiret dans le pseudo par Saxbar
- ajout dans la base de démo d'un exemple de menu déroulant vertical, horizontal et linéaire par Papinou
 

Pour passer de la version 5.00.10 à la version 5.00.11, c'est ce patch gy-non-cumulative-50011 que vous devez utiliser.

RAPPEL :

Vous devez impérativement revalider toutes les pages de config après l'installation du patch, surtout ne pas oublier Config services, avant même de vous connecter comme membre de votre site.


Merci à tous les participants à ce patch.

La GuppY Team

 

GuppY : Patch de sécurité 5.00.10 - 29 décembre 2014gylogo.png

 
Ce patch est la 88ème version de GuppY


Nous vous proposons le patch 5.00.10 avec la correction de failles.

Tous nos remerciements à Brandon  (https://www.linkedin.com/in/brandonm86), pour la découverte des failles, pour les informations transmises, pour sa coopération.

Attention, toutes les versions de GuppY sont concernées, sans exception.
Vous devez installer IMPERATIVEMENT et IMMEDIATEMENT ce patch 5.00.10 pour la sécurité de votre site.


En plus de la correction des failles nous avons ajouté dans ce patch:

- amélioration de l'envoi des courriels de Contact par Saxbar
- correction du titre du formulaire Contact par Saxbar (Boite à idées #38 - JeanDenis)
- modification de la sélection des catégories des articles par Saxbar (Boite à idées #38 - JeanDenis)
- modification des styles des liens, de la FAQ et des téléchargements par Saxbar
- amélioration de l'affichage des photoramas par Saxbar
- correction de l'affichage des icônes d'administration dans le forum par Saxbar
- correction traitement dans le formulaire d'inscription par Saxbar
- ajout traitement dans le formulaire de connexion admin par Saxbar
- ajout des groupes d'abonnés à la lettre d'information par Saxbar (Boite à idées #34 - dipisoft)
- ajout du groupe d'abonnés sélectionné dans le document lettre d'information par Saxbar (Boite à idées #34 - dipisoft)
- amélioration du traitement des groupes d'abonnés par Saxbar (Boite à idées #35 - dipisoft)
- ajout des courriels de la liste de supervision pour l'envoi du test de la lettre par Saxbar
- amélioration de l'affichage du copyright par Saxbar
- ajout du chargement du fichier de style additionnel styleplus.css par Saxbar
- ajout d'un index pour la modification de styleplus.css dans Config style par Saxbar
- amélioration de la gestion des membres et des groupes par Saxbar
- correction du fil d'Ariane du photorama en admin par Saxbar
- correction de la comparaison de version suite au nouveau format style unix par Saxbar
- correction de l'affichage de la boîte des catégories du blog en mode liste par Saxbar
- amélioration de l'affichage de la boîte nouveautés du site par Saxbar
- correction du déroulement des boîtes menus par Saxbar
- amélioration de l'affichage de la boîte photorama par Saxbar

Pour passer de la version 5.0.9 à la version 5.00.10, c'est ce patch gy-non-cumulative-50010 que vous devez utiliser.

Merci à tous les participants à ce patch.

La GuppY Team


 

GuppY : Patch non cumulatif 5.0.9 - 28 novembre 2014gylogo.png

 
Ce patch est la 87ème version de GuppY

 
Nous vous proposons le patch non cumulatif 5.0.9 pour GuppY 5.0, avec les améliorations et corrections suivantes :

- ajout d'un contrôle d'enregistrement à la connexion (merci Saxbar)
- amélioration des envois de courriels pour les contacts (merci Saxbar)
- amélioration de l'affichage de l'annuaire des téléchargements et la FAQ (merci Saxbar)
- suppression du checksum des fichiers en téléchargement (merci Saxbar)
- correction de liens en ré-écriture d'adresses des téléchargements (merci Saxbar)
- amélioration de la gestion des catégories du forum (merci Saxbar)
- amélioration de l'affichage de l'annuaire des liens (merci Saxbar)
- ajout de l'affichage pleine page du photorama et des pages secondaires (merci Saxbar)
- correction des liens en seconde langue de la recherche du blog et de l'agenda (merci Saxbar)
- correction de l'affichage des avatars externes dans le forum (merci Saxbar)
- correction du libellé du statut des collaborateurs dans le forum (merci Saxbar)
- amélioration de l'affichage du formulaire d'enregistrement des membres (merci Saxbar)
- implémentation des groupes de collaborateurs pour l'administration (merci Saxbar)
- choix de la position de l'image nouveauté des options de menu (merci Saxbar)
- ajout des options de menu hors articles dans les nouveautés du site (merci Saxbar)
- amélioration de la recherche dans la gestion des membres (merci Saxbar)
- correction du tri des billets dans les boîtes du blog (merci Saxbar)
- correction des liens dans les boîtes du blog (merci Saxbar)
- correction de l'affichage des adresses courriel du livre d'or (merci Saxbar)
- correction de la fonction UpdateDBforum() (merci Saxbar)
- correction de la visibilité du courriel des contributions du forum en mise à jour et déplacement (merci Saxbar)
- ajout de la migration du plugin iconframe (merci Saxbar)
- ajout de la migration des options de menu non-article (merci Saxbar)
- ajout de la migration du plugin contact (merci Saxbar)
- amélioration des styles pour les mobiles (merci Papinou)
- mise à jour de ckeditor en version 4.4.6 (merci Saxbar)

Pour passer de la version 5.0.8 à la version 5.0.9, c'est ce patch gy-non-cumulative-509 que vous devez utiliser.

Après l'application du patch, vous devez aller en admin/configurations/catégories de discussion pour vérifier que les catégories sont actives, si besoin cocher la case pour chaque catégorie et enregistrer pour mettre à jour l'index frcat.dtb


Merci à tous les participants à ce patch.

La Guppy Team
 

GuppY :  Patch non cumulatif 5.0.8 - 02 octobre 2014gylogo.png


Ce patch est la 86ème version de GuppY

 
Nous vous proposons le patch non cumulatif 5.0.8 pour GuppY 5.0, avec les améliorations et corrections suivantes :

- non limitation des caractères pour la saisie du nom dans le formulaire contact par Saxbar
- correction de la navigation des téléchargements, des liens et de la FAQ par Saxbar
- correction de l'affichage du courriel pour les demandes de mot de passe par Saxbar
- correction de la liste des membres dans Préférences par Saxbar
- ajout de la page secondaire pour les nouvelles par Saxbar
- paramétrage du changement de skin pour chaque membre par Saxbar
- contrôle du répertoire de sauvegarde en admin par Saxbar
- test sur la présence de la classe ZipArchive par Saxbar (merci Ludo)
- amélioration de la recherche des membres en admin par Saxbar
- correction du lien de lecture de la lettre d'information par Saxbar
- correction de règles de ré-écriture d'adresses par Saxbar
- correction de l'affichage des libellés des nouveautés du site par Saxbar
- correction de l'affichage de l'auteur des flux rss par Saxbar
- modification du calcul dans la fonction CutLongWord() par Saxbar (merci Ludo)
- correction des envois de courriels par Saxbar
- ajout de l'insertion de code dans l'éditeur pour les réactions aux articles par Saxbar
 

Pour passer de la version 5.0.7 à la version 5.0.8, c'est ce patch gy-non-cumulative-508 que vous devez utiliser.


Merci à tous les participants à ce patch.

La Guppy Team
 

GuppY : Patch non cumulatif 5.0.7 - 21 août 2014gylogo.png

 
Ce patch est la 85ème version de GuppY

Nous vous proposons le patch non cumulatif 5.0.7 pour GuppY 5.0, avec les améliorations et corrections suivantes :

- sélection en admin/configurations/config services de la position de l'icône dans le titre d'un document (merci Saxbar)
- amélioration de la gestion des membres (merci Saxbar)
- ajout de la fonction de blacklistage dans le formulaire de contact (merci Saxbar)
- création d'un annuaire de faq avec sous catégories (merci Saxbar)
- correction des liens des catégories des téléchargements (merci Saxbar)
- correction du test d'erreur dans postguest (merci Saxbar)
- correction de la largeur du dialogue de déplacement des posts du forum (merci Saxbar)
- modification des droits rédacteurs avec 2 niveaux de droits (merci Saxbar)
- modification du chemin des smileys pour l'éditeur ckeditor (merci Saxbar)
- ajout des émoticones dans l'éditeur ckeditor (merci Saxbar)
- saisie du pseudo et du courriel dans tous les documents (merci Saxbar)
- suppression des meta-tags non valides html5 (merci Saxbar)
- nombre de caractères indépendants pour forum, blog et nouvelles en page d'accueil (merci Saxbar)
- saisie de 0 pour lister la totalité des posts forum en page d'accueil (merci Saxbar)
- correction du chemin du script de post-installation dans Installer (merci Saxbar)
- correction de la suppression des photoramas dans la maintenance (merci Saxbar)
- correction des accès à l'aide des options de menu (merci Saxbar)
- affichage du nombre de membres dans la gestion des membres (merci Saxbar)
- amélioration de l'affichage de la liste des abonnés à la lettre d'information (merci Saxbar)
- chargement multiple des fichiers photos pour le photorama (merci Saxbar)
- ajout du répertoire img/plugins (merci Saxbar)
- correction des liens whois dans la boîte Préférences (merci Saxbar)
- correction des liens des options de menus articles (merci Saxbar)
- ajout d'un titre des boîtes menu déroulant linéaire (merci Saxbar)
- ajout des visites du jour dans la boîte Préférences (merci Saxbar)
- corrections des déplacements "top" et "up" des posts du forum (merci Saxbar)
- correction de la gestion des sessions des captchas texte (merci Saxbar)
- mise à jour du slideshow fotorama (merci Papinou)
- mise à jour de ckeditor en version 4.4.3 (merci Saxbar)
- correction des fichiers de style pour tablettes et mobiles (merci Papinou)

Attention, une nouveauté pour ce patch non cumulatif 5.0.7 !

La conservation automatique du renommage de vos fichiers sensibles (merci Ludo, merci Saxbar).
Avec la fonction Installer de GuppY 5.0, vous installez le patch gy-non-cumulative-507 une première fois.
Puis vous installez le patch gy-non-cumulative-507, une seconde fois, toujours avec la fonction Installer.
Après cette seconde installation, vous vous rendez en admin/configurations/config services puis Contributions visiteurs & anti-spam pour vérifier que vos fichiers renommés sont bien présents.

Pour le patch cumulatif 5.0.7, vous devez aussi appliquer ce principe de deux installations et vérifier après la seconde.

Pour passer de la version 5.0.6, de la version 5.0.6-1 à la version 5.0.7, c'est ce patch gy-non-cumulative-507 que vous devez utiliser.


Merci à tous les participants à ce patch.

La Guppy Team

gylogo.png GuppY : Patch non cumulatif 5.0.6 - 01 juillet 2014

 

Ce patch est la 84ème version de GuppY
 

Nous vous proposons le patch non cumulatif 5.0.6 pour GuppY 5.0, avec les améliorations et corrections, à savoir::

- amélioration de la gestion des membres par Saxbar
- correction du lien de retour dans le fichier error.php par Saxbar (merci Ludo)
- correction de l'écriture des logs par Saxbar (merci Ludo)
- correction de l'affichage des billets du blog dans l'édito par Saxbar
- correction de la saisie du courriel par Saxbar
- ajout de la saisie de l'adresse du site de contrôle des IPs par Saxbar
- correction des couleurs du fond des boîtes centrales et latérales par Saxbar
- correction de l'enregistrement des CHMODs
- correction de la zone de clic des options de menu déroulants par Saxbar

 
- Avant d'installer le patch, vous devez vous rendre en admin/configurations/config services/contributions visiteurs & anti-spam et remettre les noms d'origine thread.php et user.php, ces fichiers étant concernés par le patch 5.0.6.
- Après l'installation, vous devez les renommer à nouveau.

 

Pour passer de la version 5.0.5 à la version 5.0.6, c'est ce patch gy-non-cumulative-506 que vous devez utiliser.


Merci à tous les participants à ce patch.

La Guppy Team
 

gylogo.png GuppY : Patch non cumulatif 5.0.5 - 03 juin 2014

 

Ce patch est la 83ème version de GuppY
 

Nous vous proposons le patch non cumulatif 5.0.5 pour GuppY 5.0, avec les améliorations et corrections depuis le 5.0.4, à savoir:

- mise à jour de CKEditor en version 4.4.1
- mise à jour de jQuery en version 1.11.1
- correction de la navigation des articles
- correction de l'affichage des boutons impression du blog
- protection contre le copier/coller de certains champs
- amélioration du script connexion/déconnexion
- correction de l'affichage des catégories du téléchargement
- remplacement des boutons images par des boutons classiques
- correction de l'affichage du courriel visiteur du livre d'or
- correction de la navigation des pages du module de recherche
- améliorations diverses pour la conformité W3C
- correction de la suppression des membres collaborateurs
- correction des droits pour l'archivage
- correction des paramètres des photoramas
- ajout d'un lien sur le whois dans les logs
- amélioration de la gestion des membres
- implémentation de l'url-rewriting pour les plugins
- protection contre la vulnérabilité XSS du calendrier
- correction des liens de la boîte contact
- correction du lien du drapeau de langue en url-rewriting
- correction de PGEditor pour la prise en compte de Chrome 35 et IE 11.

 
- Avant d'installer le patch, vous devez vous rendre en admin/configurations/config services/contributions visiteurs & anti-spam et remettre les noms d'origine blog.php, contact.php,download.php,forum.php,guestbk.php, newsletter.php, postguest.php, thread.php et user.php, ces fichiers étant concernés par le patch 5.0.5.
- Après l'installation, vous devez les renommer à nouveau.

 

Pour passer de la version 5.0.4 à la version 5.0.5, c'est ce patch gy-non-cumulative-505 que vous devez utiliser.


Merci à tous les participants à ce patch.

La Guppy Team

gylogo.png
GuppY : Patch non cumulatif 5.0.4 - 01 mai 2014

 

Nous vous proposons le patch non cumulatif 5.0.4 pour GuppY 5.0, avec les améliorations et corrections depuis le 5.0.3, à savoir:

- la création d'un annuaire pour les liens et les téléchargements avec des catégories et des sous-catégories.
- l'affichage possible dans des pages secondaires pour les liens, les téléchargements et la FAQ
- la correction de la liste d'adresses pour les envois de supervisions
- l'ajout automatique de la configuration de page dans les adresses des options de menu
- la modification du paramétrage des photoramas, l'amélioration de l'habillage des galeries, la possibilité d'inclure ou pas une galerie dans la boite Slideshow, le choix pour chaque galerie de la déclarer comme indépendante ou pas et toujours la recommandation de choisir un nombre de miniatures raisonnable pour ne pas ralentir l'affichage de votre site.
- la correction de la classe "current" des icônes de menu supplémentaires
- la correction de la fonction d'envoi de mails


Attention:

- Le patch non cumulatif 5.0.4 contient les fichiers style.css des skins du pack GuppY pour ajouter les classes nécessaires pour l'annuaire pour les liens et les téléchargements, pour l'habillage des galeries photos.

  Si vous avez modifié manuellement une skin du pack GuppY 5.0, il est indispensable de renommer votre skin ou votre fichier style.css pour ne pas l'écraser.
  Toutes les nouvelles classes se trouvent dans la partie  /* block box lateral Article * (menu list, menu dynamic 1, menu dynamic 2) */
 

- Avant d'installer le patch, vous devez vous rendre en admin/configurations/config services/contributions visiteurs & anti-spam et remettre le nom d'origine postguest.php, contact.php et user.php, ces trois fichiers étant concernés par le patch.
- Après l'installation, vous devez les renommer à nouveau.
 

  Pour passer de la version 5.0.3 à la version 5.0.4, c'est ce gy-non-cumulative-504 que vous devez utiliser.


Merci à tous les participants à ce patch.

La Guppy Team

 

Patch GuppY 5.0.3 - 15 avril 2014gylogo.png
 

Dans ce patch, nous vous proposons toutes les corrections depuis le patch 5.0.2, à savoir:

- affichage du formulaire contact.php en page secondaire
- réorganisation des messages dans lostpass.php
- suppression de l'attribut lng dans les meta-tags
- amélioration du photorama et ajout d'une boîte latérale
- correction du paramètre d'affichage email dans postguest.php
- correction du traitement de l'étendue de recherche
- correction du traitement des sitemaps
- suppression des classes tblout et tblboxout
- correction des liens des messages des lettres d'information
- correction de la suppression des répertoires dans la gestion de fichiers
- amélioration de l'archivage

Nous avons ajouté la mise à jour de CKEditor en version 4.3.4 .
 

ATTENTION:

Le photorama a été revu avec la possibilité d'uploader des images par ftp, de configurer chaque galerie individuellement.

Une boite latérale est ajoutée avec un défilement de miniatures et au choix ImageCube ou Fotorama. Pour sélectionner l'un ou l'autre, rendez vous en admin/configurations/config services/Services Nouvelles - Photos.

L'affichage d'un grand nombre de miniatures par galerie peut ralentir l'affichage des miniatures,donc un nombre de 6 ou 12 miniatures est raisonnable.
Si vous avez déjà installé des diaporamas, vous devrez refaire la configuration de chaque diaporama, car la configuration a été modifiée.

Cette amélioration nécessite une modification du fichier style.css de votre skin. Vous avez dans le répertoire skins du patch 5.0.3, un fichier modele_photorama.css.
Vous devez copier/coller le contenu de ce fichier à la fin du fichier style.css de votre skin, et bien sur adapter les couleurs à celles de votre skin.

 

Pour passer de la version 5.0.2 à la version 5.0.3, c'est ce gy-non-cumulative-503 que vous devez utiliser.
 

Avant d'installer le patch, vous devez vous rendre en admin/configurations/config services/contributions visiteurs & anti-spam et remettre le nom d'origine postguest.php et contact.php, ces deux fichiers étant concernés par le patch.
Après l'installation, vous devez les renommer à nouveau.


Merci à tous les participants à ce patch.

La Guppy Team
 


GuppY - Patch 5.0.2 - 26 mars 2014
 

Nous vous proposons le patch 5.0.2 avec quelques corrections depuis la version 5.0.1.

- fixation à 10px du padding du code réseau social des articles
- initialisation des données utilisateur dans le formulaire contact
- correction de sécurité des formulaires contre les failles CSRF
- correction de sécurité des formulaires anti-robots
- correction de l'accès aux forums privés
- ajout d'un index pour la gestion des articles et options de menu
- modification du paramétrage de présentation des photoramas
- configuration individuelle des photoramas
- ajout d'un label à la commande de retour des messages privés
- correction d'une inversion à l'enregistrement des catégories du forum
- ajout de paramètres php dans les infos de la page A propos
- comptage des envois de lettres d'information dans un popup
- correction du blocage des menus en liste dynamique
- correction de la zone de saisie des boîtes recherche
- correction de la gestion des images de nouveauté des articles
- correction de l'écriture des sitemaps dans robots.txt
- correction de l'import des documents ayant $ dans le contenu
 

Pour passer de la version 5.0.1 à la version 5.0.2, c'est ce gy-non-cumulative-502 que vous devez utiliser.
 

ATTENTION ! Après avoir appliqué ce patch, vous devez immédiatement lancer le script de mise à jour du nouvel
index qui fait le lien entre articles et options de menu.

Pour cela, dans la barre d'adresse de votre navigateur tapez ceci :
http://votre_site/maj_index_arom.php

 

Pour les diaporamas, surtout ne bidouillez pas n'importe quoi, d'autres modifications sont en cours et seront dans le prochain patch.

 
Merci à tous les participants à ce patch.

La Guppy Team



GuppY - Patch_nc_5.0.1 - 10 mars 2014

Nous vous proposons le patch nc 5.0.1 pour GuppY avec les modifications décrites ci-dessous.

Ce sont les corrections de défauts issus de vos retours d'expérience.

- tri de la table des années pour la navigation dans l'agenda
- corrections du contrôle du captcha et des STOP no file ! dans le contact avancé
- les dimensions des avatars externes passent à 64x64
- correction de $colorTextTitre dans tous les scripts  config_upload
- correction des dates du calendrier en mode répétition
- saisie des valeurs préconisées pour les dossiers et les fichiers dans Config générale
- écriture des fonctions SetChmod() et MakeDir() en remplacement des fonctions php
- possibilité d'utiliser les menus déroulants dans les emplacements de la page d'accueil
- possibilité d'insérer la boîte compteurs de visites dans la boîte Préférences
- correction du contrôle d'accès aux menuicons en admin
- améliorations dans le traitement de la hauteur des nouvelles et billets du blog en page d'accueil
- corrections des descriptions des éléments ainsi que le contenu par défaut des fils RSS
- correction du traitement du titre du site pour les apostrophes
- correction de l'affichage du copyright dans la version texte
- élimination des doublons lors de la migration
- correction de la migration de l'agenda

La GuppY Team

 

GuppY 5.0.0 est sorti !!! - 25 février 2014


Vous voulez construire un site pour présenter vos passions, documenter un logiciel que vous utilisez, partager vos photos, parler de vous ou communiquer avec autrui ?

Vous avez envie d'un site complet, interactif, avec un livre d'or, un blog, un forum, un système de news, un annuaire, une FAQ, une galerie (...) et la possibilité d'ajouter sans peine de nouveaux modules ?

Vous n'avez malheureusement aucune connaissance en HTML, PHP, mySQL ?

Essayez GuppY 5.0 !
Plus qu'une simple évolution, cette version est une véritable révolution !

Oui elle est bien là cette version majeure très attendue !

Après deux ans de développement de nombreuses versions pré-alpha, alpha, vingt-trois versions bêta, cinq versions RC et quelques corrections de dernière minute.

GuppY 5.0 dispose de HTML5, CSS3 et jQuery, le codage en UTF8, les boites illimitées, l'affichage des boites en différentes largeurs au choix de l'utilisateur, les menus déroulants horizontaux et verticaux, la nouvelle configuration des pages, les configurations secondaires illimitées, une fonction d'installation, une fonction de sauvegarde, la réécriture d'adresses, l'aide en ligne avec la possibilité de l'intégrer au site...

Les changements sont nombreux, prenez le temps de les découvrir et de les apprivoiser.

Un bon point de départ semble la découverte sur toutes ses pages de la partie admin et de ses possibilités nouvelles. Dans la partie admin, lorsque vous verrez un point d'interrogation dans le coin supérieur droit, n'hésitez pas à cliquer pour voir ce qu'il cache, ça devrait vous être utile.

En plus de cette extraordinaire version de GuppY 5.0, vous pourrez découvrir le "Centre d' Aide GuppY " ainsi qu'un superbe tutoriel concernant les skins V5.

Merci aux traducteurs qui souhaitent participer au projet GuppY. Vous pouvez envoyer vos fichiers de traduction après lecture des règles de copyright à guppy [ @ ] freeguppy.org.

Pour tous renseignements complémentaires, merci de nous contacter sur ce courriel exclusivement.

Pour en savoir plus sur le grand nombre de nouveautés incluses dans cette version 5 de GuppY, rendez-vous au plus vite sur le site de www.freeguppy.org et son forum dédié à la V5.
 

La GuppY Team.

GuppY - Patch de sécurité 4.6.28 - 12 octobre 2013

Nous vous proposons le patch 4.6.28 avec la correction de deux failles XSS pouvant
permettre l'injection de code et la correction d'un couic pour mktime dans agenda ( merci Saxbar, jchouix, JeanMi )

Merci au High-Tech Bridge Security Research Lab pour le signalement.

Attention, toutes les versions de GuppY sont concernées, sans exception.
Vous devez installer IMPERATIVEMENT et IMMEDIATEMENT ce correctif pour la sécurité de votre site.


Comme à chaque nouvelle version, n'oubliez pas de mettre à jour vos plugins, de réinstaller vos forks, de revalider vos pages de configuration.
Pour passer de la version 4.6.26, 4.6.27, 4.6.27-1 à la version 4.6.28, c'est ce patch_nc_4628 que vous devez utiliser.

  
Merci pour votre compréhension et toutes nos excuses pour ces erreurs.

Merci à tous les participants à ce patch.


La Guppy Team

 

GuppY - Patch de sécurité 4.6.27-1 - 11 octobre 2013

Nous vous proposons le patch 4.6.27-1 avec la correction de deux failles XSS pouvant
permettre l'injection de code et la correction d'un couic pour mktime ( merci Saxbar, jchouix, JeanMi )

Merci au High-Tech Bridge Security Research Lab pour le signalement.

Attention, toutes les versions de GuppY sont concernées, sans exception.
Vous devez installer IMPERATIVEMENT et IMMEDIATEMENT ce correctif pour la sécurité de votre site.


Comme à chaque nouvelle version, n'oubliez pas de mettre à jour vos plugins, de réinstaller vos forks, de revalider vos pages de configuration.
Pour passer de la version 4.6.26 à la version 4.6.27-1, c'est ce patch_nc_4627-1 que vous devez utiliser.

  
Merci à tous les participants à ce patch.

La Guppy Team


A 22h00 le 11.10.2013, correction du fichier inc/functions.php,  passage du pack et des patchs en 4.6.27-1

 

GuppY - Patch_nc_4.6.26 - 10 août 2013

Pour améliorer la lutte contre le spam, nous vous proposons le patch_nc_4626 avec:
- la correction de la configuration du renommage des fichiers (merci Saxbar)
et nous en profitons pour:
- apporter des corrections sur des failles concernant les groupes privés du forum découvertes lors de tests de renommage (merci Saxbar)

Pour la sécurité de vos sites, nous recommandons l'installation de ce patch rapidement.

Nous vous rappelons qu'un modèle de htaccess pour bloquer les IP de spam est en téléchargement dans la rubrique Télécharger de freeGuppY.

Si les catégories de votre forum sont toujours à l'ancien format, vous devez lancer le script "maj_forumcat.php" pour remettre les IDs des catégories au bon format, par exemple: 1,PR1 au lieu de PR1 .


Comme à chaque nouvelle version, n'oubliez pas de mettre à jour vos plugins, de réinstaller vos forks, de revalider vos pages de configuration.
Pour passer de la version 4.6.25 à la version 4.6.26, c'est ce patch_nc_4626 que vous devez utiliser.


Merci à tous les participants à ce patch.


La GuppY Team

 

GuppY patch_nc_4625 - 11 juin 2013

Dans la continuité de la lutte contre le spam, nous vous proposons le patch_nc_4625 avec:

- 1 - le renommage du fichier download.php selon le même principe que les autres fichiers - merci Saxbar .
- 2 - la correction de l'affichage de Prévisualiser et Imprimer dans blog.php - merci Saxbar .

Avant l'installation de ce patch 4.6.25, vous devez lire le tutoriel mis à jour et inclus en pdf :
" tuto_configurer_ANTI-SPAM " et le suivre à la lettre .

Comme à chaque nouvelle version, n'oubliez pas de mettre à jour vos plugins, de réinstaller vos forks, de revalider vos pages de configuration.
Pour passer de la version 4.6.24 à la version 4.6.25, c'est ce patch_nc_4625 que vous devez utiliser.


EXCEPTIONNELLEMENT, le patch_nc_4624 reste en téléchargement sur freeGuppY, nous vous rappelons que son installation est URGENTE pour le bon fonctionnement et la sécurité de votre site .

 
Merci à tous les participants à ce patch.


La GuppY Team
 


GuppY - Patch_nc_4.6.24 - 07 juin 2013

Nous vous proposons le patch nc 4.6.24 pour GuppY avec plusieurs modifications visant toutes à lutter contre le spam.

Nous recommandons l'installation en urgence de ce patch de sécurité .


Depuis deux mois, nous sommes confrontés :

- 1 - au spam sur le livre d'or ou les nouvelles, bloqué jusqu'à ce jour par Cryptographp
- 2 - aux requêtes des robots spammeurs à partir de postguest.php vers le livre d'or et les nouvelles.

Voici le genre de requêtes pour GuppY :

http://monsite.fr/postguest.php?lng=en&typ=gb
http://monsite.fr/postguest.php?lng=en&typ=ne
http://monsite.fr/postguest.php?lng=fr&typ=gb
http://monsite.fr/postguest.php?lng=fr&typ=ne
 

 Les scripts des robots ne tapent pas au hasard mais en partant des noms de fichiers standards qui se trouvent dans les scripts open source des CMS, car il n'y a pas que GuppY à être ciblé.
Ces requêtes amènent une surcharge du serveur en mutualisé et suivant les hébergeurs, les sites sont suspendus, postguest est bloqué en chmod 200 ou encore renommé.


Le patch 4.6.24 avec la proposition de renommage des fichiers et l'intégration de Cryptographp vise à apporter une réponse aux 2 problèmes (Merci Saxbar).
Toutes les modifications des fichiers concernent le renommage des fichiers, l'intégration de Cryptographp avec une configuration par défaut fonctionnelle, à l'exception des fichiers admin/inc/upload.inc (correction d'une coquille ligne 219 et de l'affichage du tableau ligne 220 à 225 - merci Laroche)


Date de création : 25/02/2014 @ 14:54
Catégorie : Le CMS GuppY - Un CMS unique
Page lue 8746 fois

Vous êtes ici :   Accueil » Historique des versions
 
Préférences

Se reconnecter :
Votre nom (ou pseudo) :
Votre mot de passe
eRFP
Recopier le code :


  13036954 visiteurs
  6 visiteurs en ligne

Connectés :
membresanne_b64
Newsletter
Pour avoir des nouvelles de ce site, inscrivez-vous à notre Newsletter.
eRFP
Recopier le code :
Site enregistré à la CNIL sous l'agrément 1040387.
Vous disposez d'un droit d'accès, de modification, de rectification
et de suppression des données selon la loi Informatique et Liberté (article 34) du 6 janvier 1978.

FreeGuppY.org est hébergé sur un serveur dédié Nuxit


 


Nuxit Partenaire de GuppY
 

    gy_twitter02.png